Package Details: phonesim 1.21.r16.gadf231a-1

Git Clone URL: https://aur.archlinux.org/phonesim.git (read-only, click to copy)
Package Base: phonesim
Description: Phone Simulator for modem testing
Upstream URL: https://git.kernel.org/pub/scm/network/ofono/phonesim.git/
Keywords: ofono phonesim
Licenses: GPL2
Submitter: BloodyAltair
Maintainer: BloodyAltair
Last Packager: BloodyAltair
Votes: 2
Popularity: 1.13
First Submitted: 2019-10-23 02:09
Last Updated: 2020-05-29 07:18

Pinned Comments

BloodyAltair commented on 2019-11-29 20:42

UPD: As developers of phonesim didn't provide any dependency list for it, I've made it manually in three steps:

  1. I've analyzed ldd output and recognized dynamic libraries needed to run phonesim

  2. I've found packages providing these dynamic libraries (using pkgfile utility)

  3. I've removed explicitly unneeded dependencies from package list (e.g. glibc)

So it definetly should work, but on the different ArchLinux-like distros, the package list may be a bit different

Latest Comments

BloodyAltair commented on 2020-05-29 07:01

@rafaelff thanks for your comment! I've made suggested changes, please try it out :)

rafaelff commented on 2020-05-28 19:16

+1 to @flortsch comment: qt5-declarative fixed the following cmake output:

checking for QT... no
configure: error: Qt is required
==> ERROR: A failure occurred in build().

Also, namcap reports "GPLv2" is not a common license. Changing the license to "GPL2" solves this issue.

flortsch commented on 2020-04-26 20:37

I think this package is missing qt5-declarative as dependency, as I couldn't build/run without installing it.

BloodyAltair commented on 2020-03-09 14:18

@stuartiannaylor I have updated, please try it out

stuartiannaylor commented on 2020-03-06 14:00

The latest Master now is QT5 not QT4 so prob needs an update

BloodyAltair commented on 2019-11-29 20:42

UPD: As developers of phonesim didn't provide any dependency list for it, I've made it manually in three steps:

  1. I've analyzed ldd output and recognized dynamic libraries needed to run phonesim

  2. I've found packages providing these dynamic libraries (using pkgfile utility)

  3. I've removed explicitly unneeded dependencies from package list (e.g. glibc)

So it definetly should work, but on the different ArchLinux-like distros, the package list may be a bit different

BloodyAltair commented on 2019-11-29 20:32

@scott

Firstly, phonesim is linked with libQtGui.so, which is only provided by qt4. So I can neither remove this dependency nor upgrade the version to qt5. If you want phonesim to be upgraded for a new version of the Qt library - ask its' developers (see Upstream URL field in the package's head block)

Secondly, the qt4 package is available in the community repository for Manjaro and AUR for ArchLinux ( I've tested, it's working on ArchLinux )

So, you don't need neither mark this package out of date nor delete Qt5, you just need to install qt4 from AUR and use it

P.S. You're not alone, I also using phonesim only to make ofono+pulseaudio+HFP work =)))

scott commented on 2019-11-29 19:53

Apologies in advance for the ignorance implicit in this question: I can't build this package because qt4 is a dependency; makepkg/pacman returns "error: target not found" about qt4. Of course, I do have qt5 installed. So 1. do I flag the package as OutOfDate and request that you "do what it takes" to change the dependency to qt5? or 2. ask you where I can find qt4 and install it (thereby running both qt4 and qt5? or 3. Something else? Thanks! PS: if it helps to know: in my case, i really "only" need phonesim in order to get ofono to enable pulseaudio to support the HFP profile that my bluetooth speakerphone actually supports -- so that I can use its microphone. There seems to be a very complete explanation at https://freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Bluetooth/ on how to do this