Package Details: phantomjs 2.1.1-14

Git Clone URL: https://aur.archlinux.org/phantomjs.git (read-only, click to copy)
Package Base: phantomjs
Description: Headless WebKit with JavaScript API
Upstream URL: http://www.phantomjs.org/
Licenses: BSD, LGPL, MIT
Submitter: yan12125
Maintainer: TheGoliath
Last Packager: TheGoliath
Votes: 19
Popularity: 0.035003
First Submitted: 2018-01-24 14:25
Last Updated: 2020-04-25 09:25

Pinned Comments

yan12125 commented on 2018-08-12 11:22

FAQ

  • error while loading shared libraries: libicui18n.so.61: cannot open shared object file: No such file or directory

You can either to reinstall this package afte upgrading the system to ICU 62, or install the prebuilt package listed below.

  • Building takes too long time!

A: PhantomJS ships with its own Qt and QtWebKit. Just be patient.

Latest Comments

« First ‹ Previous 1 2 3 4

yan12125 commented on 2018-04-18 05:38

@andreymal: Most likely there's something wrong in your toolchain/environment. It's suggested to always build this package in clean chroots.

FYI:

$ du /usr/bin/phantomjs 
50M     /usr/bin/phantomjs

andreymal commented on 2018-04-17 21:21

$ du -h /usr/bin/phantomjs
1,3G    /usr/bin/phantomjs

WTF

yan12125 commented on 2018-04-17 12:40

sanduhrs flagged phantomjs out-of-date on 2018-04-17 for the following reason:

Latest release is 2.1.3
<https://github.com/ariya/phantomjs/releases>

READ COMMENTS BELOW. NOW.

MacNuke commented on 2018-04-04 08:11

for anyone wondering: phantomjs is dead for now:

https://github.com/ariya/phantomjs/issues/15344

yan12125 commented on 2018-03-06 12:37

Your package phantomjs [1] has been flagged out-of-date by simon04

Version 2.1.3 is out. #simon04/aur-out-of-date

WTF

yan12125 commented on 2018-03-04 05:34

Version 2.1.3 is out. #simon04/aur-out-of-date

@kewl: Please read comments below carefully before marking this package as out-of-date.

yan12125 commented on 2018-01-30 16:38

NOTICE: Version 2.1.3 is out, while it doesn't build due to the following issues:

https://github.com/ariya/phantomjs/issues/15235

https://github.com/ariya/phantomjs/issues/15291

So 2.1.1 is the latest version that can be built from sources. Checkout out aur/phantomjs-bin for prebuilt binaries.

yan12125 commented on 2018-01-24 18:41

Reference build time: 2 hours (without multithreading)