Package Details: pgplot 5.2.2-7

Git Clone URL: https://aur.archlinux.org/pgplot.git (read-only)
Package Base: pgplot
Description: Fortran- or C-callable, device-independent graphics package for making simple scientific graphs.
Upstream URL: http://www.astro.caltech.edu/~tjp/pgplot/
Licenses: custom
Submitter: Snowman
Maintainer: AstroFloyd
Last Packager: AstroFloyd
Votes: 19
Popularity: 0.001120
First Submitted: 2006-07-09 01:10
Last Updated: 2015-07-27 17:25

Latest Comments

1 2 Next › Last »

AstroFloyd commented on 2019-07-27 11:21

Apologies for the delay. I'm not a Perl user myself - is this due to the absence of the demo programs (in other words, does it work with your own Perl code)?

ng0177 commented on 2019-06-17 18:34

I get this error despite of all recent packages installed.

pdl> demo pgplot Undefined subroutine &PDL::Demos::PGPLOT_demo::run called at /usr/bin/site_perl/perldl line 453, <STDIN> line 2. at /usr/bin/site_perl/perldl line 453, <STDIN> line 2. main::demo("pgplot") called at (eval 68) line 4 main::ANON() called at /usr/bin/site_perl/perldl line 719 eval {...} called at /usr/bin/site_perl/perldl line 719 main::eval_and_report("demo 'pgplot'\x{a}") called at /usr/bin/site_perl/perldl line 655 main::process_input() called at /usr/bin/site_perl/perldl line 675 eval {...} called at /usr/bin/site_perl/perldl line 675

Universebenzene commented on 2016-11-20 17:28

BTW, why not install the pgdemos with the package? I think It's a good idea to check it with the demos after installing.

AstroFloyd commented on 2015-08-10 18:41

I have updated the PKGBUILD with the fixes mentioned before.

AstroFloyd commented on 2015-05-09 13:33

I found the following issues:
* the library should be linked against X11
* makepkg now seems to require a package() function

The following patch should fix your PKGBUILD:
http://paste.pound-python.org/show/gwZLgSzOXkEPz5osJ9p5/

AstroFloyd commented on 2015-05-09 11:18

makepgk now seems to require a package() function. This patch achieves that in your PKGBUILD: http://paste.pound-python.org/show/vBjDN8xGy11W7G4LXvS7/

GNRS commented on 2013-07-06 17:05

I am a little lost with this package... I need it as a dependence of other libraries. In Ubuntu this works fine, but in Arch Linux I get things like this:

---
PGPLOT /xw: Waiting for pgxwin_server to start (timeout in 7 seconds).
PGPLOT /xw: Timed out waiting for program pgxwin_server to start


PGSTAR: failed to open /xwin

please check that X Window System is running
and that you have set the environment variables
DISPLAY :0
PGPLOT_DEV /xwin
and also that you have set PGPLOT_DIR and PGPLOT_FONT
---

I don't have an Ubuntu installation to test it right now, but I think that executing pgxwin_server should open a small window, but in Arch Linux (if I execute pgxwin_server manually) it doesn't do anything. Any ideas?

I am not sure if I should ask this here, sorry if this is not the place.

jmorin commented on 2012-09-20 14:44

Build depedency to gcc-fortran added.

Anonymous comment on 2012-03-06 00:37

I did it first! I demand recognition :)
http://pastebin.com/G9rRPAy2

P.S. sorry for the dead link in original post

jmorin commented on 2012-03-05 09:06

Thanks for the patch, the PKGBUILD is updated. I checked on a few programs that it works for me, let me know if you something is wrong for you.