Package Details: pgl-cli 2.3.1-1

Git Clone URL: https://aur.archlinux.org/pgl-cli.git (read-only, click to copy)
Package Base: pgl-cli
Description: A privacy oriented firewall application (Daemon & CLI).
Upstream URL: http://sourceforge.net/projects/peerguardian/
Licenses: GPL3
Conflicts: pgl, pgl-git
Provides: pgl
Submitter: Gilrain
Maintainer: Gilrain
Last Packager: Gilrain
Votes: 26
Popularity: 0.000000
First Submitted: 2011-08-25 13:04
Last Updated: 2016-01-14 14:34

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

tsr-nc commented on 2012-11-30 15:44

please add this to /usr/lib/systemd/system/pgl.service for systemd compatibility
Requires=iptables.service
After=iptables.service

Gilrain commented on 2012-11-13 08:43

dbus is now enabled by default since systemd requires it anyway.

pgl 2.2.2

[jre]
* changed default to not log to syslog (LOG_SYSLOG="0")
* fixed pending ";" in IP_REMOVE results in empty blocklist
* added "env" to the example WGET_OPTS for proxies. Closes: SF bug #3581707
* fixed reading ipfilter.dat lines which contain a : in the decription
* updated documentation

[hasufell]
* added gentoo init script, accessible via --with-gentoo-init
* cleaned up configure.ac (AM_CFLAGS)

[freemind]
* fixed bug that prevented apply button from getting enabled.
* modified iptables related functions to use always port numbers and not
names (fix)
* fixed pglgui crashes if you try to whitelist permanently, while pgl is not
running.
* code refacturing

Gilrain commented on 2012-04-26 08:59

@trex279: I'm sorry but I cannot reproduce your problem, both with makepkg or directly on a specially crafted set of files.
The only explanation I can see is that your local PKGBUILD has, somehow, a different sed line than the one posted online.

trex279 commented on 2012-04-26 05:27

I get an error when I try to build it:

~/build/pgl-cli/PKGBUILD: line 30: /bin/sed: Argument list too long
==> ERROR: A failure occurred in build().
Aborting...

Gilrain commented on 2012-04-20 08:21

@ponsfoot: logrotate files have been added to the backup array. Thanks for reporting.

ponsfoot commented on 2012-04-19 15:13

Hi,
Could you add the following files into backup=()?
/etc/logrotate.d/pglcmd
/etc/logrotate.d/pgld
Thx.

Anonymous comment on 2012-01-28 20:54

Thank you Gilrain (see? got it right this time -_- )
I was using the PKGBUILD in the tarball.

Now everything is working fine.

Fabio.

Gilrain commented on 2012-01-28 20:13

@SnowDruid: The "last update" refers to the modified PKGBUILD (revision number 2.1.3-2 replacing 2.1.3-1) which got rid of the DBUS dependency. You must recompile your package using the updated PKGBUILD/Archive to benefit from this.
Pardon the lack of clarity.

Anonymous comment on 2012-01-28 19:12

Hello again Gilran, thanks for the reply.

I'm using the last update:
[root@doom ~]# pgld

ERROR: No blocklist specified!

pgl 2.1.3

pgl is licensed under the GNU General Public License v3, or (at your option)
any later version. This program comes with ABSOLUTELY NO WARRANTY. This is
free software, and you are welcome to modify and/or redistribute it.

I'm sorry - I don't think I understand. Maybe I'm missing something, but looking at /var/log/errors.log it seems the program looks for dbus.

Fabio.

Gilrain commented on 2012-01-28 18:59

@SnowDruid: the last update no longer needs a running dbus daemon to function.