Package Details: perl-xml-mini 1.38-4

Git Clone URL: https://aur.archlinux.org/perl-xml-mini.git (read-only, click to copy)
Package Base: perl-xml-mini
Description: XML::Mini - Perl implementation of the XML::Mini XML create/parse interface
Upstream URL: https://metacpan.org/release/XML-Mini
Licenses: GPL, PerlArtistic
Provides: perl-xml-mini-document, perl-xml-mini-element, perl-xml-mini-element-cdata, perl-xml-mini-element-comment, perl-xml-mini-element-doctype, perl-xml-mini-element-entity, perl-xml-mini-element-header, perl-xml-mini-node, perl-xml-mini-treecomponent
Submitter: dracorp
Maintainer: dracorp
Last Packager: dracorp
Votes: 2
Popularity: 0.030528
First Submitted: 2012-08-29 10:49
Last Updated: 2021-05-03 17:05

Latest Comments

micwoj92 commented on 2021-05-01 19:48

Ok I just checked, on Manjaro pacman indeed depends on perl. This is not the case for Arch Linux and this is Arch User Repository, not Manjaro User Repository. Please add perl to depends. Thank you.

dracorp commented on 2021-05-01 19:43

But openssl is not pacman. I update my system every few days. Ok, I'm using Manjaro, mainly. On both computers.

micwoj92 commented on 2021-05-01 19:26

Unless you haven't updated your system in couple months that is not the case. Openssl used to depend on perl but does not anymore. Then you would have pacman > curl > openssl > perl

https://github.com/archlinux/svntogit-packages/commit/513ff8ae0c62e48aa405a7ee1088fce784e759f4#diff-3e341d2d9c67be01819b25b25d5e53ea3cdf3a38d28846cda85a195eb9b7203a

dracorp commented on 2021-05-01 19:14

Not exactly:

❯ pactree -r perl -a | grep pacman
|-pacman

The pacman depends from perl.

micwoj92 commented on 2021-04-30 22:58

Just because a package is in core does not mean that it should be removed from depends. You can have perfectly fine Arch install without perl installed. Want proof? do sudo pacman -Rcns perl and you can see that base package does not get removed. Please re add perl to depends. Thank you.

dracorp commented on 2021-04-30 22:23

core/perl

micwoj92 commented on 2021-04-30 20:14

uhm, why delete perl from depends???

micwoj92 commented on 2021-04-29 02:09

Hello, could you update links to https?

Anonymous comment on 2013-01-14 04:01

The source link is out of date. Should be: http://search.cpan.org/CPAN/authors/id/P/PD/PDEEGAN/XML-Mini-1.38.tar.gz