Package Details: perl-wx 0.9932-3

Git Clone URL: https://aur.archlinux.org/perl-wx.git (read-only, click to copy)
Package Base: perl-wx
Description: Interface to the wxWidgets cross-platform GUI toolkit
Upstream URL: https://metacpan.org/dist/Wx
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 58
Popularity: 0.000000
First Submitted: 2007-09-20 07:29
Last Updated: 2021-11-08 16:06

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 Next › Last »

swiftgeek commented on 2015-05-20 09:00

And
[ -z "$DISPLAY" ] && makedepends+=('xorg-server-xvfb')
to make sure user has it if it will be needed
(I made similar changes to perl-wx-glcanvas if you would like to compare)

swiftgeek commented on 2015-05-19 15:22

Please add:
xvfb-run -a -s "-screen 0 1280x1024x24" make test
in case if [ -z $DISPLAY ] , so it could have chance of passing on headless machine

Also cleaning up PKGBUILD from Build.pl would be nice
wxgtk is mentioned twice - in makedeps and deps which isn't proper

bugrepoter2814 commented on 2015-05-18 01:43

This is what i get as one of the errors, before the test report (mine is the same as Reded)

The library used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8)

It might be relevant

Reded commented on 2015-05-17 22:48

local/perl 5.20.2-1 (base)
A highly capable, feature-rich programming language

latest as far as I can see!

I'll try in a TTY and see how that goes.

dracorp commented on 2015-05-17 16:01

@Reded:
So you can tray to compile the package without X. But it is strange for me.
Just out of curiosity, what's your version of perl?

Reded commented on 2015-05-17 15:46

I'm still failing to build this - getting this error - https://paste.linuxdistrocommunity.com/view/fdca6d5b

I'm running Enlightenment, some people mentioned tiling wm's so maybe it's my wm messing things up? I'll try again later on with Openbox.

dracorp commented on 2015-05-13 19:34

I could not compile the package because I had set PERL5LIB, so if you have problems then unset this env.

Anonymous comment on 2015-05-11 12:12

v 0.9927 avaible

DonHansDampf commented on 2015-04-28 16:38

Did you change something? I reinstalled to the same machine (switched from HDD to SSD). Installed the same WM etc. Everything the same. This time i was able to install perl-wx without a problem.

nickoe commented on 2015-04-12 14:08

@03data, what wm? I am using i3 and it works.