Package Details: perl-wx 0.9932-3

Git Clone URL: https://aur.archlinux.org/perl-wx.git (read-only, click to copy)
Package Base: perl-wx
Description: Interface to the wxWidgets cross-platform GUI toolkit
Upstream URL: https://metacpan.org/dist/Wx
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 58
Popularity: 0.000000
First Submitted: 2007-09-20 07:29
Last Updated: 2021-11-08 16:06

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

markzz commented on 2015-08-15 17:54

This package is wacky, it builds on certain machines of mine, but doesn't on others of mine.

swiftgeek commented on 2015-07-22 14:35

@bricewge: start from posting actual full log with wxgtk3.x , also check dmesg for anything segfaulting
Log from building perl-alien-wxwidgets is also important

Whole purpose of perl-alien-wxwidgets package is to selects used version of wxgtk (during its build)

bricewge commented on 2015-07-22 11:07

atomsvote and Reded are right this package doesn't build if you don't mess around with the PKGBUILD.

If the tests failed, first recompile perl-alien-wxwidgets with wxgtk2.8, by uncommenting "HAX" in the PKGBUILD, and then compile perl-wx with it depends as wxgtk2.8 instead of wxgtk. Then it will compile and pass the test fine.

@dracorp can you fix this directly in the PKGBUILD?

Logs of the tests with wxgtk=3.0: https://paste.linuxdistrocommunity.com/view/09b87da7

meZee commented on 2015-06-04 03:32

This package fails to build when https://aur.archlinux.org/packages/freshplayerplugin-git/ is installed, even when adobe proprietary is also installed.

Reded commented on 2015-05-31 20:57

@atomsvote - Yes this worked, thanks!

I should add that in the perl-alien-wxwidgets PKGBUILD I also had to uncomment the section about building against wxgtk2.8 instead of 3, otherwise THAT package would fail to build too.

dracorp commented on 2015-05-28 21:18

@atomsvote: these are only metadata, they do not directly affect the process of building.

swiftgeek commented on 2015-05-28 13:44

• Still works fine on 3.x line
• Read README again, notice that it was made whole eons ago - last tested with perl 5.10!
• Provide logs

I have only minor issues (warnings) with archlinux repo's wxgtk and audacity not being compiled against 3.x (had to rebuild it manually - so now there is no wxgtk2.8 on my system, x86_64 to be exact)

swiftgeek commented on 2015-05-28 13:40

Still works fine on 3.x line

atomsvote commented on 2015-05-28 13:33

Hi, I also had the failed test problem when building this package on a new clean distribution, the problem is related to wxgtk version:

depends=(
wxgtk
)

wxgtk is now version 3.0.2-4(https://www.archlinux.org/packages/extra/i686/wxgtk/)
but perl-wx is only tested wit wxgtk 2.8 or 2.9 (http://cpansearch.perl.org/src/MDOOTSON/Wx-0.9927/README.txt)

So in order to build this you need to change wxgtk version to the follow:

depends=(
wxgtk2.8
)

You need to change this on this package and perl-alien-wxwidgets dependency

In order to build this you must need to remove wxgtk, install wxgtk2.8 and rebuild perl-alien-wxwidgets(don't forget to change the version of wxgtk), then rebuild this package.


@Reded can you confirm if this work for you ?

dracorp commented on 2015-05-20 15:19

Thx swiftgeek, I forgot about this.