Package Details: perl-wx 0.9932-3

Git Clone URL: (read-only, click to copy)
Package Base: perl-wx
Description: Interface to the wxWidgets cross-platform GUI toolkit
Upstream URL:
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 58
Popularity: 0.000000
First Submitted: 2007-09-20 07:29
Last Updated: 2021-11-08 16:06

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

dracorp commented on 2017-06-02 19:04

It builds well with the newest version.

xcMI2w commented on 2017-06-02 18:02

When will this package be fixed?
I'm on gcc 7.1.1

Heitor commented on 2017-02-27 18:55

You're right. The problem is the version of GCC. The pacman says I have GCC 6.3.1, but GCC tells me 5.4.0. I dont know if I choose a wrong way. I removed the folder "/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0" and maked a symbolic link: "sudo ln -s /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1 /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0". Works fine.

Problem solved!

Thank you.

ivan_p commented on 2017-02-27 16:35

Might be gcc version: 6.3 is in [extra], but your log shows 5.4.
gcc 6 uses C++11 standard by default, gcc 5 needs it to be enabled (just like the error mentions).

Heitor commented on 2017-02-27 15:42

My version of wxgtk is the same:

$ pacman -Ss wxgtk
extra/wxgtk 3.0.2-6 [installed]

I need perl-wx for sli3r...


dracorp commented on 2017-02-23 17:31

It works for me.
Which version of wxgtk? 3.0.2-6?

Heitor commented on 2017-02-22 21:28

I can't install perl-wx:

/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/c++/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.

/usr/include/wx-3.0/wx/strvararg.h:350:18: error: ‘is_enum’ in namespace ‘std’ does not name a template type
typedef std::is_enum<T> is_enum;
/usr/include/wx-3.0/wx/strvararg.h:354:54: error: ‘is_enum’ was not declared in this scope
enum { value = wxFormatStringSpecifierNonPodType<is_enum::value>::value };
/usr/include/wx-3.0/wx/strvararg.h:354:68: error: template argument 1 is invalid
enum { value = wxFormatStringSpecifierNonPodType<is_enum::value>::value };

Any idea? Thanks!

dracorp commented on 2016-08-30 19:06

@lbeenens: I've added those dependencies to checkdepends.

lbeenens commented on 2016-08-29 22:14

The current version of the package (0.9928-3) has no problem building with the incompatible ABI versions. So, there is no need to go back to wxgtk2.8.

However, building the package can fail at the stage of testing the module WX::WebView: this package depends on webkitgtk(i686)/webkitgtk2(x86_64), which is not stated in the PKGBUILD.

swiftgeek commented on 2016-04-01 04:40

It isn't, but it isn't explicitly required even though it sanitizes check stage
So it's just nice to use it when available or required when building headless