Package Details: perl-wx 0.9932-3

Git Clone URL: https://aur.archlinux.org/perl-wx.git (read-only, click to copy)
Package Base: perl-wx
Description: Interface to the wxWidgets cross-platform GUI toolkit
Upstream URL: https://metacpan.org/dist/Wx
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 58
Popularity: 0.000000
First Submitted: 2007-09-20 07:29
Last Updated: 2021-11-08 16:06

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11

Anonymous comment on 2011-11-21 21:37

New version out, which new Padre needs.
CPAN_VERSION 0.9903

Anonymous comment on 2011-08-30 10:24

I've got a same problem as jceasless, all deps seem to be installed. Can anyone help?

Anonymous comment on 2011-07-05 14:41

perl-extutils-makemaker is included with perl, btw

Anonymous comment on 2011-01-16 23:01

Missed dependencies:
perl-extutils-makemaker
and
perl-extutils-xspp (please read comments carefully)

Anonymous comment on 2010-09-10 13:48

I get the following error when trying to install perl-wx:


Writing 'cpp/ovl_const.cpp'.
touch wxt_overload
make[1]: Entering directory `/tmp/bauerbill/build/aur/perl-wx/src/Wx-0.98/ext'
make[2]: Entering directory `/tmp/bauerbill/build/aur/perl-wx/src/Wx-0.98/ext/richtext'
cp lib/Wx/RichText.pm ../../blib/lib/Wx/RichText.pm
/usr/bin/perl /usr/share/perl5/core_perl/ExtUtils/xsubpp -noprototypes -nolinenumbers -typemap /usr/share/perl5/core_perl/ExtUtils/typemap -typemap ../../typemap -typemap typemap RichText.xs > RichText.xsc && mv RichText.xsc RichText.c
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextCtrl.xsp' in RichText.xs, line 65
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextAttr.xsp' in RichText.xs, line 67
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextStyle.xsp' in RichText.xs, line 69
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextStyleCtrl.xsp' in RichText.xs, line 71
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextFormattingDialog.xsp' in RichText.xs, line 73
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextFileHandler.xsp' in RichText.xs, line 75
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextBuffer.xsp' in RichText.xs, line 77
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/SymbolPickerDialog.xsp' in RichText.xs, line 79
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextStyleOrganiserDialog.xsp' in RichText.xs, line 81
Error: Function definition too short 'INCLUDE_COMMAND: $^X -MExtUtils::XSpp::Cmd -e xspp -- -t typemap.xsp -t ../../typemap.xsp XS/RichTextPrinting.xsp' in RichText.xs, line 83
make[2]: *** [RichText.c] Error 1
make[2]: Leaving directory `/tmp/bauerbill/build/aur/perl-wx/src/Wx-0.98/ext/richtext'
make[1]: *** [subdirs] Error 2
make[1]: Leaving directory `/tmp/bauerbill/build/aur/perl-wx/src/Wx-0.98/ext'
make: *** [subdirs] Error 2
Aborting...

xenoterracide commented on 2010-08-21 02:35

@Athaba if you want maintainership email the maintainer, if he doesn't respond in a week mail the aur mailing list and ask them to orphan it, then you adopt.

Athaba commented on 2010-06-12 11:40

If you don't want to maintain it anymore.
Please give up maintainership!

Athaba commented on 2010-05-26 14:49

Please update to 0.9702 and fix your package.

==> Install or build missing dependencies for perl-wx:
==> Building and installing package

==> perl-wx dependencies:
- perl (already installed)
- wxgtk (already installed)
- perl-alien-wxwidgets (already installed)
- perl-data-dumper (package that provides perl-data-dumper already installed)
- perl-extutils-parsexs (package that provides perl-extutils-parsexs already installed)
- perl-extutils-xspp (already installed)
- perl-extutils-makemaker (package that provides perl-extutils-makemaker already installed)
- wxgtk (already installed)
==> Making package: perl-wx 0.9701-1 i686 (Wed May 26 16:47:30 CEST 2010)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Installing missing dependencies...
perl-extutils-parsexs>=2.2202 package not found, searching for group...
error: 'perl-extutils-parsexs>=2.2202': not found in sync db
==> ERROR: Pacman failed to install missing dependencies.
Error: Makepkg was unable to build perl-wx package.