Package Details: perl-wx 0.9932-3

Git Clone URL: https://aur.archlinux.org/perl-wx.git (read-only, click to copy)
Package Base: perl-wx
Description: Interface to the wxWidgets cross-platform GUI toolkit
Upstream URL: https://metacpan.org/dist/Wx
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 58
Popularity: 0.000001
First Submitted: 2007-09-20 07:29
Last Updated: 2021-11-08 16:06

Latest Comments

1 2 3 4 5 6 ... Next › Last »

yar commented on 2021-11-10 11:08

I'm unable to build with devtools/makechrootpkg, errors very similar to what @ibrokemypie got almost 4 years ago. I can't figure out why. Could you please test with devtools to confirm?

yochananmarqos commented on 2021-10-31 15:46

@xiretza: I just built it just fine with wxgtk2 3.0.5.1-2, no need for wxgtk2.8.

xiretza commented on 2021-07-24 08:47

Doesn't build with wxwidgets 3.0 (https://rt.cpan.org/Public/Bug/Display.html?id=128994), wxgtk dependency needs to be changed to wxgtk2.8 (https://aur.archlinux.org/packages/wxgtk2.8/).

Adelie commented on 2021-05-07 00:15

I'm getting

No such 'link' library: 'adv' at /home/build/.cache/yay/perl-wx/src/Wx-0.9932/build/Wx/build/MakeMaker.pm line 212.

bartus commented on 2021-01-12 09:22

wxgtk was dropped from provides array in wxgtk2

PKGBUILD needs replacing wxgtk with wxgtk2 in depends array.

dracorp commented on 2018-02-01 18:56

@ibrokemypie You have something missing and why are you using gcc 3.4?

% gcc --version
gcc (GCC) 7.2.1 20180116

ibrokemypie commented on 2018-01-31 13:48

i was able to fix this by running export CC=clang, export CXX=clang++ and replacing perl Makefile.PL in the pkgbuild with perl Makefile.pl --extra-cflags=-std=c++11

ibrokemypie commented on 2018-01-31 13:38

currently failing to build at all for me

==> Making package: perl-wx 0.9932-2 (Thu Feb  1 00:37:51 AEDT 2018)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Wx-0.9932.tar.gz
==> Validating source files with sha256sums...
    Wx-0.9932.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting Wx-0.9932.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Searching configuration for:
wxWidgets (any version) for (any toolkit); compiler compatibility: gcc 3.4; 

Available configurations:
wxWidgets 3.000003 for gtk2; compiler compatibility: nc 0; options: no debug, unicode, no mslu
Compilation failed in require at Makefile.PL line 21.
BEGIN failed--compilation aborted at Makefile.PL line 21.
==> ERROR: A failure occurred in build().
    Aborting...

dracorp commented on 2017-12-28 11:53

@christianlupus: fixed, thx

dracorp commented on 2017-12-28 10:14

webkit2gtk vs webkitgtk2