Package Details: perl-net-cups 0.64-1

Git Clone URL: https://aur.archlinux.org/perl-net-cups.git (read-only, click to copy)
Package Base: perl-net-cups
Description: Common Unix Printing System Interface
Upstream URL: https://metacpan.org/release/Net-CUPS
Licenses: GPL, PerlArtistic
Submitter: sputnick
Maintainer: guzzisti
Last Packager: guzzisti
Votes: 4
Popularity: 0.000799
First Submitted: 2010-03-19 18:26
Last Updated: 2020-07-03 06:20

Latest Comments

1 2 Next › Last »

Markus.N commented on 2020-07-12 17:15

I've found my mistake ... I didn't do a clean rebuild. I'm using yay for AUR packages, and I usually like to see the differences in the packages, that's why I'm used to build without cleaning. In this case, a clean was needed.

guzzisti commented on 2020-07-03 06:20

@jakeobsen Thanks for the hint, i've added the dep.

jakeobsen commented on 2020-07-02 17:19

Hi, I'm on a fresh install of arch and I'm trying to install perl-net-cups, however it fails to build. I have tracked it down to a missing dependency of: cups-filters

Please add this package as a dependency.

Markus.N commented on 2020-06-30 13:16

Yes, I've rebuilt.

Markus.N commented on 2020-06-29 21:00

Yes, the perl update was several weeks ago. And several reboots. :-) I just tried to fix the pacman warning about remaining perl packages in 5.30. All packages except this one succeeded by reinstalling.

severach commented on 2020-06-29 19:39

then reinstalled

A reboot isn't necessary. Does reinstalled mean installed same package or rebuild? You need to rebuild.

guzzisti commented on 2020-06-29 08:52

@Markus.N: Just tried myself and it successfully installs in /usr/lib/perl5/5.32/

Have you rebooted after updating to Perl 5.32?

Markus.N commented on 2020-06-29 07:40

Always installs into /usr/lib/perl5/5.30, even though perl has been updated to 5.32. Just did pacman -R perl-net-cups, then reinstalled, and is still in 5.30.

leong commented on 2015-01-18 13:32

Should be flagged out of date

leong commented on 2015-01-18 13:31

cups version too old ????

cups and libcups Version: 2.0.1-1
cups-filters Version: 1.0.62-1

prompt$ yaourt -S perl-net-cups

Net::CUPS Configuration
Running cups-config ... 2.0.1
The version of the Common Unix Printing System installed
on your system is too old for this module to work properly.
Please upgrade the version of CUPS on your system to version
1.2.2 or higher and re-run Makefile.PL to install this module.

2.0.1 > 1.2.2 How could my cups version be too old ?

I tried to force my cups version to 1.2.2 in Makefile.pl but the compilation stops with many warnings and errors.