Package Details: perl-moose 2.2012-2

Git Clone URL: https://aur.archlinux.org/perl-moose.git (read-only, click to copy)
Package Base: perl-moose
Description: A postmodern object system for Perl 5
Upstream URL: https://metacpan.org/release/Moose
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: Ordoban
Last Packager: Ordoban
Votes: 79
Popularity: 0.006533
First Submitted: 2009-04-20 16:45
Last Updated: 2020-01-12 17:15

Required by (167)

Sources (1)

Pinned Comments

jnbek commented on 2016-06-07 16:40

Ugh, even after the perl 5.24 upgrade, we're still getting errors in makepkg:

Warning: prerequisite List::Util 1.45 not found. We have 1.4202.

List::Util is a core module... we need this module to be version 1.45 before we can update this pkgbuild and it's millions of reverse-deps

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

mbunkus commented on 2014-06-04 19:26

Please update as the current version segfaults, even if re-built against Perl 5.20.0. Thanks.

chimeracoder commented on 2014-04-29 00:28

@ahills Thanks - I've fixed that (and updated to 2.1205).

ahills commented on 2014-04-23 22:02

The second to last dependency in the list has a syntax error (a comma). This causes many, but not all, AUR helpers to fail, as the comma is considered a part of the version number.

pascal.ilya commented on 2014-02-19 10:32

Ok, thanks. It's work.

sacarde commented on 2014-02-16 10:58

@pascal.ilya

I solve upgrading from aur:

pacaur -S perl-moose

installing perl-devel-stacktrace too

pascal.ilya commented on 2014-02-15 13:26

Anybody, can you help me? I realy need moose. Thanks

pascal.ilya commented on 2014-02-15 08:20

Hello. I install perl-devel-stacktrace from AUR but I still have same error as sacarde:
Files=460, Tests=53, 112 wallclock secs ( 4.91 usr 1.96 sys + 96.26 cusr 11.02 csys = 114.15 CPU)
Result: FAIL
Failed 437/460 test programs. 28/53 subtests failed.
Makefile:2771: recipe for target 'test_dynamic' failed
make: *** [test_dynamic] Error 4

Thanks.

sacarde commented on 2014-02-15 07:54

ok

now works OK


thanks

chimeracoder commented on 2014-02-14 23:36

@frankspace Thanks, I've added it as a dependency.

frankspace commented on 2014-02-14 13:49

I notice from the metacpan page for perl-moose that perl-devel-stacktrace is now a dependency. I was also unable to compile, but when I installed perl-devel-stacktrace the problems went away and perl-moose compiles perfectly. Would you please add that to the dependencies in the PKGBUILD?