Package Details: perl-moose 2.2012-2

Git Clone URL: https://aur.archlinux.org/perl-moose.git (read-only, click to copy)
Package Base: perl-moose
Description: A postmodern object system for Perl 5
Upstream URL: https://metacpan.org/release/Moose
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: Ordoban
Last Packager: Ordoban
Votes: 79
Popularity: 0.005595
First Submitted: 2009-04-20 16:45
Last Updated: 2020-01-12 17:15

Required by (167)

Sources (1)

Pinned Comments

jnbek commented on 2016-06-07 16:40

Ugh, even after the perl 5.24 upgrade, we're still getting errors in makepkg:

Warning: prerequisite List::Util 1.45 not found. We have 1.4202.

List::Util is a core module... we need this module to be version 1.45 before we can update this pkgbuild and it's millions of reverse-deps

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

BluePeril commented on 2015-03-16 06:40

Sorry but I disagree to the cpu architecture independents. It contains /usr/lib/perl5/vendor_perl/auto/Moose/Moose.so and I get
file /usr/lib/perl5/vendor_perl/auto/Moose/Moose.so
/usr/lib/perl5/vendor_perl/auto/Moose/Moose.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked

chimeracoder commented on 2015-03-16 01:24

@godofgrunts Thanks, I've updated the PKGBUILD accordingly.

godofgrunts commented on 2015-03-15 19:08

Alright sorry, I've been commenting as I go, but this should be the last one, I'll sum everything up in this comment.

Arch needs to be changed to arch=('any') as this is not cpu architecture dependent (confirmed by installing on my cubebox i which is arm7)

perl-devel-overloadinfo needs to be moved to makedepends instead of checkdepends as it's actually needed to build.

godofgrunts commented on 2015-03-15 18:57

Actually, I see that it has it listed already; however, mine failed saying it needed perl-devel-overloadinfo which I had to get from https://aur.archlinux.org/packages/perl-devel-overloadinfo/

Strange.

godofgrunts commented on 2015-03-15 18:13

PKGBUILD also needs perl-devel-overloadinfo as a dependency

godofgrunts commented on 2015-03-15 17:57

This PKGBUILD can be set to arch('any')

frankspace commented on 2014-11-22 06:56

Thanks to atweiden for submitting the perl-devel-overloadinfo package; confirming that after installing that, perl-moose compiles as it should.

atweiden commented on 2014-11-21 15:53

I received the same compilation error.

perl-moose should checkdepends=('perl-devel-overloadinfo')

frankspace commented on 2014-11-20 13:24

Compilation fails for me, almost all tests resulting in "Dubious." I note the following warning, though:

The following REQUIRED prerequisites were not satisfied:
Devel::OverloadInfo is not installed (version '0.002' required)

Nothing of the sort appears to be found in any respository. I'm afraid I'm not clever enough to know the answer, but is that possibly the problem? Thanks!

sxe commented on 2014-10-08 14:13

Hi chimeracoder,
i already tried that but changes nothing.
I still get the same error even after reinstalling "perl-params-util".