Package Details: perl-moose 2.2013-1

Git Clone URL: (read-only, click to copy)
Package Base: perl-moose
Description: A postmodern object system for Perl 5
Upstream URL:
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: Ordoban
Last Packager: Ordoban
Votes: 79
Popularity: 0.000046
First Submitted: 2009-04-20 16:45
Last Updated: 2020-07-22 06:16

Required by (166)

Sources (1)

Pinned Comments

jnbek commented on 2016-06-07 16:40

Ugh, even after the perl 5.24 upgrade, we're still getting errors in makepkg:

Warning: prerequisite List::Util 1.45 not found. We have 1.4202.

List::Util is a core module... we need this module to be version 1.45 before we can update this pkgbuild and it's millions of reverse-deps

Latest Comments

1 2 3 4 5 6 ... Next › Last »

bidulock commented on 2020-03-26 07:20

Package contains ELF files and must not be an "any" package.

jthvai commented on 2020-01-12 14:01

perl-module-runtime-conflicts should probably be added to the dependency list, as pacman will refuse to build this package without it.

J5lx commented on 2018-10-17 13:00

As bidulock wrote a while ago, the architecture of this package should not be any since it contains native code. Instead, supported architectures should be explicitly named (i.e. x86_64).

plaxx commented on 2018-08-09 18:44

You need to bump perl-devel-overloadinfo to perl-devel-overloadinfo>=0.005

dracorp commented on 2017-06-20 17:32

And with perl-5.26.0-1:
xs/Moose.c: loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080)
on Makefile.PL -> check_conflicts()
After adding to PKGBUILD:
sed '16s/^/#/' -i Makefile.PL
I can install and use this module. How good is it?

bidulock commented on 2017-06-11 04:12

Builds ok with 5.26.0, however this is not an 'any' package.

yar commented on 2017-04-18 00:31

This should makedepend on at least perl-type-tiny and perl-specio, probably others. I'm getting lots of test failures and have to run --nocheck

Vrob commented on 2017-01-02 00:08

Installing community/perl-scalar-list-utils fixed the error complaining about version 1.4202 of List::Util. Maybe this package should be added as a dependency?

somercet commented on 2016-07-20 09:29

I have a PKGBUILD for Scalar-List-Utils 1.45 and can submit it.

It does not appear to conflict with extra/perl-list-moreutils or community/perl-list-allutils.

mbunkus commented on 2016-06-11 08:13

You could create an AUR package for List::Util (perl-list-util) and tell people to install that one manually. That's what I did a couple of months ago in a similar situation.