Package Details: perftest 4.4.0.9-1

Git Clone URL: https://aur.archlinux.org/perftest.git (read-only, click to copy)
Package Base: perftest
Description: OpenFabrics Alliance Infiniband verbs performance testing and benchmarking tools
Upstream URL: https://www.openfabrics.org/index.php/overview.html
Licenses: GPL2, custom:"OpenIB.org BSD"
Submitter: twinshadow
Maintainer: jamespharvey20 (nfnty)
Last Packager: jamespharvey20
Votes: 2
Popularity: 0.000000
First Submitted: 2011-12-29 23:56
Last Updated: 2019-11-20 03:15

Latest Comments

Arcanum commented on 2021-02-18 01:01

Will not build

In file included from /usr/include/sys/time.h:21,
                 from src/get_clock.c:43:
/usr/include/features.h:187:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
  187 | # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
      |   ^~~~~~~
  CC       src/perftest_communication.o
  CC       src/perftest_parameters.o
  CC       src/perftest_resources.o
  CC       src/perftest_counters.o
  CC       src/raw_ethernet_resources.o
  AR       libperftest.a
ar: `u' modifier ignored since `D' is the default (see `U')
  CCLD     ib_send_bw
/usr/bin/ld: libperftest.a(raw_ethernet_resources.o):/home/user/.cache/rua/build/perftest/src/perftest-4.4-0.9/src/raw_ethernet_resources.c:58: multiple definition       of `duration_param'; libperftest.a(perftest_resources.o):/home/user/.cache/rua/build/perftest/src/perftest-4.4-0.9/src/perftest_resources.c:41: first defined here
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:738: ib_send_bw] Error 1
make[1]: Leaving directory '/home/user/.cache/rua/build/perftest/src/perftest-4.4-0.9'
make: *** [Makefile:580: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
Build failed with exit code 4 in /home/user/.cache/rua/build/perftest

ajs124 commented on 2017-11-26 16:22

https://gist.github.com/ajs124/91695b1de3a280f92cf3c02afe58a343

twinshadow commented on 2013-01-21 22:21

rdma_bw and rdma_lat don't appear to be built anymore. Removing the offending files from the install line in the PKGBUILD resolves the packaging, so I'll update the release in a few minutes to reflect this.

Thanks for the feedback!

jmsq commented on 2013-01-21 20:30

I'm getting this when trying to build:

==> Starting package()...
install: cannot stat ‘rdma_bw’: No such file or directory
install: cannot stat ‘rdma_lat’: No such file or directory
==> ERROR: A failure occurred in package().

Upon further inspection those two binaries aren't getting built on my system. Am I missing a dependency/option?