Package Details: pencil 3.1.0-3

Git Clone URL: https://aur.archlinux.org/pencil.git (read-only, click to copy)
Package Base: pencil
Description: Sketching and GUI prototyping/wireframing tool
Upstream URL: http://github.com/evolus/pencil
Keywords: prototyping sketching wireframe
Licenses: GPL2
Conflicts: evolus-pencil-bin, pencil-v2
Submitter: tinhtruong
Maintainer: lysergia
Last Packager: lysergia
Votes: 185
Popularity: 0.49
First Submitted: 2012-10-11 10:13
Last Updated: 2020-06-19 17:19

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

lysergia commented on 2015-07-18 23:53

I(the app's maintainer) can take back package maintainer status if you'd like.

lysergia commented on 2015-05-29 02:10

New version includes below fixes & 3rd party stencil collections as optional dependencies.

geosam commented on 2015-05-27 02:08

Thanks @reci

hmrodrigues commented on 2015-05-26 18:31

@reci it worked. Thanks

reci commented on 2015-05-26 17:24

Change lines in /usr/share/evolus-pencil/application.ini to this:

...
[Gecko]
MinVersion=36.0
MaxVersion=38.*

Works for me.

hmrodrigues commented on 2015-05-26 08:38

Same problem of @Neuromancien and @rouhouch fix doesn't work for me

Neuromancien commented on 2015-05-25 19:52

It does not work for me :
/usr/bin/pencil contains :
BINARIES="xulrunner"

But I still get the error :
(process:7145): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '38.0.1' is not compatible with
minVersion >= 36.0
maxVersion <= 37.*

lysergia commented on 2015-05-18 18:38

Thanks for the reports, I've fixed this upstream and will put a new version out within the next few days.

ronjouch commented on 2015-05-18 17:59

I have the same problem as @florianb : I use a more recent firefox (40.0a2 currently), living in a bin folder that I prepend to my $PATH. This results in the `pencil` script finding it and preferring it to the correctly-at-37.0 xulrunner installed as a dependency of pencil:

(process:8731): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '40.0a2' is not compatible with
minVersion >= 36.0
maxVersion <= 37.*

Problem is easily fixed by editing `/usr/bin/pencil` and just leaving BINARIES="xulrunner". Maintainer could fix this properly by adding a break statement in the for loop searching for a binary. Thanks for the packaging! Nice to see someone caring for this neat app.

florianb commented on 2015-05-18 17:49

does not work for me.

$ pencil

(process:24164): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Error: Platform version '38.0.1' is not compatible with
minVersion >= 36.0
maxVersion <= 37.*