Package Details: pencil 3.1.0-6

Git Clone URL: https://aur.archlinux.org/pencil.git (read-only, click to copy)
Package Base: pencil
Description: Sketching and GUI prototyping/wireframing tool
Upstream URL: https://github.com/evolus/pencil
Keywords: prototyping sketching wireframe
Licenses: GPL2
Conflicts: evolus-pencil-bin, pencil-v2
Submitter: tinhtruong
Maintainer: lysergia (BrLi)
Last Packager: BrLi
Votes: 186
Popularity: 0.22
First Submitted: 2012-10-11 10:13
Last Updated: 2020-10-13 16:54

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

pyr commented on 2019-08-15 12:01

Since a recent upgrade (within the last month) I cannot start pencil anymore, it fails with the following message at startup:

Hardware acceleration disabled for Linux.
zsh: segmentation fault (core dumped)  pencil

edoantonioco commented on 2018-05-09 15:06

it stays at

'>node install.js

and after many minutes:

/tmp/yaourt-tmp-eduardo/aur-pencil/src/pencil-3.0.4/node_modules/electron/install.js:46 throw err ^

Error: read ECONNRESET at TLSWrap.onread (net.js:659:25) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin-win@2.1.1 (node_modules/7zip-bin-win): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for 7zip-bin-win@2.1.1: wanted {"os":"win32","arch":"any"} (current: {"os":"linux","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin-mac@1.0.1 (node_modules/7zip-bin-mac): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for 7zip-bin-mac@1.0.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! electron@1.4.14 postinstall: node install.js npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the electron@1.4.14 postinstall script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /home/eduardo/.npm/_logs/2018-05-09T15_19_24_097Z-debug.log ==> ERROR: Se produjo un fallo en package(). Cancelando... ==> ERROR: Makepkg no ha podido compilar pencil.

rpodgorny commented on 2017-12-29 15:13

you probably need to recompile (relink to be exact) with the new libs (icui18n, ...)...

Aaron_chen commented on 2017-12-29 14:54

"node: error while loading shared libraries: libicui18n.so.60: cannot open shared object file: No such file or directory" why?

richardm commented on 2017-11-17 15:35

not working at all on my side... requiring 7zip for Windows (...)

zypang commented on 2017-10-30 10:55

I have solved the problem. It should be caused by pacaur. I installed it manually with makepkg successfully.

zypang commented on 2017-10-30 09:48

I got stuck at "node install.js" when I tried to install it with pacaur. My Arch system is up-to-date. Does anyone encounter the same problem?

dotmagic commented on 2017-09-26 18:13

Can we make NPM dependency optional? I'd like to install & update npm by myself without pacman.

lysergia commented on 2017-09-18 17:02

I added it to fix the failing post-install step:
https://github.com/evolus/pencil/issues/397

I don't know if this is the best/perfect solution, suggestions or other fixes are welcome.

miopa commented on 2017-09-18 16:00

I noticed this change in build script, can someone explain why it's needed?

```
- HOME="$TMP_HOME" npm install
+ HOME="$TMP_HOME" npm install --unsafe-perm
```