Package Details: peervpn 0.044-4

Git Clone URL: https://aur.archlinux.org/peervpn.git (read-only)
Package Base: peervpn
Description: An open source peer-to-peer VPN
Upstream URL: http://www.peervpn.net
Keywords: mesh vpn
Licenses: GPL3
Submitter: None
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 12
Popularity: 0.125102
First Submitted: 2009-01-15 18:59
Last Updated: 2019-01-21 19:10

Latest Comments

1 2 Next › Last »

dark-saber commented on 2019-01-21 19:16

@ruantu Thank you! Yes, this openssl 1.0 is a pain to get rid of.

ruantu commented on 2019-01-18 03:52

Let's throw away openssl 1.0

ruantu commented on 2019-01-18 03:51

@dark-saber Here has a peervpn upgrade openssl-1.1 support patch. https://github.com/opnsense/ports/blob/4c72afdb6f71047be07592c4c96f94994acc7567/opnsense/peervpn/files/patch-openssl-devel

azrdev commented on 2017-09-19 09:49

@wevcode I'm fine with that, disowning it. have fun!

azrdev commented on 2017-06-28 09:53

@jwh thanks, I added your patch. Hope it works, didn't test the package, since I'm not using peervpn anymore.

Related to that, if anybody else likes to takeover the package, I'm happy to hand it over.

jwh commented on 2017-06-28 03:16

This is broken now due to openssl 1.1, but the following patch to the Makefile fixes it, will also need openssl-1.0 adding to depends:

--- Makefile.orig 2017-06-28 04:16:06.670811840 +0100
+++ Makefile 2017-06-28 04:13:47.405943014 +0100
@@ -1,5 +1,5 @@
-CFLAGS+=-O2
-LIBS+=-lcrypto -lz
+CFLAGS+=-O2 -I/usr/include/openssl-1.0
+LIBS+=-L/usr/lib/openssl-1.0 -lcrypto -lz

all: peervpn
peervpn: peervpn.o

sapk commented on 2016-08-24 19:20

Also work on aarch64

socke commented on 2015-07-19 19:10

Actually, setting the architecture to "any" isn't propably the best solution, since then for example packages built on x86_64 can be easily installed on an arm machine but wouldn't run there. "any" is only meant for packages which are truly platform independent (e.g. documentation, scripts, configurations, ...).

azrdev commented on 2015-02-27 13:06

If anyone is annoyed by a lot of "warning: could not send packet!" messages in the journal, try this: https://gist.github.com/azrdev/4c9b2729dae36973de66

Also, if you have feedback regarding (lacking) support of architectures or anything else, just tell me.

dark-saber commented on 2015-02-13 18:58

It builds and runs without any problems on armv5tel (Pogoplug) and armv6l(RPi).