Package Details: peerflix 0.39.0-1

Git Clone URL: https://aur.archlinux.org/peerflix.git (read-only, click to copy)
Package Base: peerflix
Description: Streaming torrent client for node.js
Upstream URL: https://github.com/mafintosh/peerflix
Licenses: MIT
Submitter: heddson
Maintainer: heddson
Last Packager: heddson
Votes: 57
Popularity: 1.37
First Submitted: 2014-03-18 19:42
Last Updated: 2018-06-15 15:36

Latest Comments

1 2 3 Next › Last »

qark commented on 2020-09-12 19:07

Could you please apply patch from https://github.com/mafintosh/peerflix/pull/357 ? Looks like upstream is dead and this issue is really annoying.

paulodiovani commented on 2019-07-25 19:20

Please, fix node_modules dir permissions, you can add this at the end of package() find "$pkgdir/usr" -type d -exec chmod 755 '{}' +

Nitsuga commented on 2018-06-16 12:31

I'm not sure why, but all directories under usr/lib/node_modules/peerflix/node_modules have 777 permissions!

Tharbad commented on 2018-05-15 23:43

Getting: error: failed to commit transaction (conflicting files) peerflix: /usr/lib/node_modules/peerflix/node_modules/brace-expansion/LICENSE exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/debug/src/inspector-log.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/dns-packet/opcodes.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/dns-packet/rcodes.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/inquirer/node_modules/lodash/_safeGet.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/ipaddr.js/lib/ipaddr.js.d.ts exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/mime/CHANGELOG.md exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/mime/src/build.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/mime/src/test.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/rc/cli.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/rusha/.babelrc exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/rusha/.eslintrc.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/rusha/dist/rusha.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/rusha/dist/rusha.min.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/thunky/.npmignore exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/thunky/.travis.yml exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/thunky/test.js exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/ultron/README.md exists in filesystem peerflix: /usr/lib/node_modules/peerflix/node_modules/ws/lib/.DS_Store exists in filesystem Errors occurred, no packages were upgraded.

heddson commented on 2017-07-20 22:53

I got the same issue after updating npm.. Seems to be an issue with npm 5. Got around it by adding the path to the tarball.

I'm not too keen on using the registry name with 'npm install' as young.acinonyx suggested. That would download it from the registry, instead of using the already downloaded source taball..

Updated the PKGBUILD.

damien commented on 2017-07-18 05:13

Thanks young.acinonyx, that PKGBUILD works for me.

young.acinonyx commented on 2017-07-18 00:09

I compiled this package with the following PKGBUILD and it worked:

pkgname=peerflix
pkgver=0.37.0
pkgrel=1
pkgdesc="Streaming torrent client for node.js"
arch=('any')
url="https://github.com/mafintosh/peerflix"
license=('MIT')
depends=('nodejs')
makedepends=('npm')
options=(!emptydirs)
source=("https://github.com/mafintosh/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('f8b870d88baa138c195bec7fd8c6d0f52718a3a4da949caccc168a96de99ba2f')

package() {
cd "${srcdir}/${pkgname}-${pkgver}"

install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
npm install -g --prefix "${pkgdir}/usr" peerflix
}

# vim:set ts=2 sw=2 et:

heddson commented on 2017-07-17 15:57

Strange. I get the following output:

$ file /usr/lib/node_modules/peerflix
/usr/lib/node_modules/peerflix: directory

damien commented on 2017-07-17 14:56

Hi, the latest release doesn't seem to be working for me.

I believe this is the problem:

$ file /usr/lib/node_modules/peerflix
/usr/lib/node_modules/peerflix: broken symbolic link to ../../../../../src/peerflix-0.37.0

heddson commented on 2015-10-06 19:10

Hi! Yeah I saw that to.. When I run 'grep -R "$(pwd)" pkg' I get alot of hits.

The references to pwd doesn't matter, but I concur that it's not that nice to have those warnings.

I don't know how to how to hide/remove it (without using some ugly hack with sed or something).. I'll have to investigate it some more.