Package Details: pdi-ce 8.1.0.0_365-1

Git Clone URL: https://aur.archlinux.org/pdi-ce.git (read-only)
Package Base: pdi-ce
Description: Pentaho Data Integration (ETL) a.k.a Kettle
Upstream URL: https://community.pentaho.com/projects/data-integration/
Licenses: Apache
Submitter: oxplot
Maintainer: oxplot
Last Packager: oxplot
Votes: 6
Popularity: 0.192220
First Submitted: 2017-09-21 04:03
Last Updated: 2018-05-23 22:43

Latest Comments

« First ‹ Previous 1 2

marco44 commented on 2017-11-03 08:09

It is installed yes...

I solved this by rebuilding kettle completely (7.1.0.5).

oxplot commented on 2017-11-03 04:36

@cousinm nope. Did you install webkitgtk2? I got some hanging when I uninstalled mine for testing.

marco44 commented on 2017-11-02 09:51

There are a lot of place where it hangs when right clicking, such as the view tab. It happens even when using an unpackaged version, so it doesn't come from your package, but do you have this issue too?

marco44 commented on 2017-10-24 14:22

Thanks a lot !

oxplot commented on 2017-10-24 12:45

@cousinm fixed all commands to accept arguments and added pan.

marco44 commented on 2017-10-24 08:39

Another detail: the kitchen shell doesn't work:

#!/bin/sh
cd /opt/pdi
exec ./kitchen.sh

should be

#!/bin/sh
cd /opt/pdi
exec ./kitchen.sh $@

kitchen takes parameters (such as -file), these should be forwarded to the script.

marco44 commented on 2017-10-24 08:30

Hi, and thanks for maintaining this. Could you please add pan as an executable ? I often use it to run standalone transformations. Not an emergency, as it is still available from opt, there is no need to make everyone reinstall the package for this, but it would be nice to have it in a future version.

Thanks a lot.

oxplot commented on 2017-10-11 08:46

@Sigi Seems like it needs webkitgtk2 from AUR but after uninstalling mine, the only thing I notice is that it opens the welcome screen and docs in firefox instead of inside one of the built-in tabs. I guess that's not a good UX so I'll add webkitgtk2 as a dep.

As for the other issue, can you give me a KTR that has this issue so I can reproduce it.

Sigi commented on 2017-10-11 08:32

Tx for maintaining it!

I do get an error/warning at startup:

WARNING: no libwebkitgtk-1.0 detected, some features will be unavailable
Consider installing the package with apt-get or yum.
e.g. 'sudo apt-get install libwebkitgtk-1.0-0

It is also stated at the pentaho linux ubuntu page to download the libwebkitgtk thing.

And your installation also runs in this issue:
https://stackoverflow.com/questions/30712608/operation-in-progress-never-ends-when-previewing-rows-in-kettle-spoon-via-s
I had the same issue when downloading pentaho manually.