Package Details: pcl 1.11.1-2

Git Clone URL: https://aur.archlinux.org/pcl.git (read-only, click to copy)
Package Base: pcl
Description: A comprehensive open source library for n-D Point Clouds and 3D geometry processing
Upstream URL: http://www.pointclouds.org
Licenses: BSD
Submitter: None
Maintainer: majorx234
Last Packager: majorx234
Votes: 42
Popularity: 0.91
First Submitted: 2011-04-05 03:39
Last Updated: 2021-05-02 10:01

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

majorx234 commented on 2021-05-02 10:03

@dobedobedo: ok, I added your suggested line in the cmake options.

dobedobedo commented on 2021-05-01 20:38

The package cannot build until I add -DCMAKE_CXX_STANDARD=14 to cmake options.

majorx234 commented on 2020-11-26 20:35

@JanSurf: thx! I suggested these changes to the OpenNI aur package. Hope it will be also fixed in openni upstream due to your pull request.

JanSurft commented on 2020-11-26 17:37

@majorx234: Yes it seems to work.

I did the following actions to check:

git clone https://github.com/majorx234/openni_PKGBUILD.git
cd openni_PKGBUILD
aur build -f
sudo pacman -S openni 
# choose reinstall yes

aur fetch pcl
cd pcl
aur build -f
sudo pacman -S pcl
# choose reinstall yes

Everything compiled well.

majorx234 commented on 2020-11-26 10:52

@JanSurf: here is my openni PKGBUILD +patches: https://github.com/majorx234/openni_PKGBUILD.git

could you try it out and give me feedback if this is working? Thx

JanSurft commented on 2020-11-26 08:14

@majorx234: thanks for reproducing and your helpful information!

Unfortunately I need openni for connection to an ORBBEC Astra.

I did apply the patch, but I had to change it because it was failing due to wrong line-numbers and line-endings being patched. After that the pcl package does compile further (currently at 25% ;) ).

For future reference I created a new pull request with correct patch-information for the openni-master-branch.

majorx234 commented on 2020-11-25 17:32

@JanSurf: I can reproduce your error. If i installed openni, I've got also a lot (>7000) errors. In the OpenNI package (which isn't updated since 2 years) they suggested a patch (if you don't need OpenNI, easiest solution would be to uninstall OpenNI)

JanSurft commented on 2020-11-25 15:05

I encounter compilation errors with the latest version, below an excerpt:

/usr/include/ni/XnPlatform.h:73:3: error: #error OpenNI Platform Abstraction Layer - Unsupported Platform!
   73 |  #error OpenNI Platform Abstraction Layer - Unsupported Platform!
      |   ^~~~~
In file included from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/include/pcl/io/openni_camera/openni.h:47,
                 from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/include/pcl/io/openni_camera/openni_image.h:44,
                 from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/include/pcl/io/pcd_grabber.h:50,
                 from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/src/pcd_grabber.cpp:39:
/usr/include/ni/XnOS.h:51:3: error: #error OpenNI OS Abstraction Layer - Unsupported Platform!
   51 |  #error OpenNI OS Abstraction Layer - Unsupported Platform!
      |   ^~~~~
In file included from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/include/pcl/io/openni_camera/openni.h:50,
                 from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/include/pcl/io/openni_camera/openni_image.h:44,
                 from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/include/pcl/io/pcd_grabber.h:50,
                 from /home/jan/aur/pcl/src/pcl-pcl-1.11.0/io/src/pcd_grabber.cpp:39:
/usr/include/ni/XnCppWrapper.h:10045:76: error: macro "XN_VALIDATE_NEW" passed 4 arguments, but takes just 2
10045 |    XN_VALIDATE_NEW(pTrans, StateChangedCallbackTranslator, handler, pCookie);
      |        

Can anybody reproduces these errors? There are 7803 lines of error in my compilation output.

majorx234 commented on 2020-11-20 09:47

@petronny: thx, this is fixed now

petronny commented on 2020-11-20 08:15

Hi, you have a hardcoded '-j8' in PKGBUILD. That should be set in /etc/makepkg.conf rather than here. Please remove it from PKGBUILD.