Package Details: paru 1.5.1-1

Git Clone URL: https://aur.archlinux.org/paru.git (read-only, click to copy)
Package Base: paru
Description: Feature packed AUR helper
Upstream URL: https://github.com/morganamilo/paru
Keywords: AUR helper pacman rust wrapper yay
Licenses: GPL3
Submitter: Morganamilo
Maintainer: Morganamilo
Last Packager: Morganamilo
Votes: 162
Popularity: 52.84
First Submitted: 2020-10-19 00:43
Last Updated: 2021-04-13 20:11

Dependencies (6)

Required by (1)

Sources (1)

Latest Comments

1 2 Next › Last »

KerfuffleV2 commented on 2021-04-16 01:53

@andrej It would be helpful to include more information like the version of rustc you're using. Latest stable (1.51.0) doesn't seem to have any issues with alpm 1.1.8. Another thing to try is possibly running "cargo update" - maybe something in the dependency tree is outdated.

andrej commented on 2021-04-12 21:54

I’m running into E0367 when trying to build this (caused by alpm).

   Compiling alpm v1.1.8
error[E0367]: The requirement `for<'b> T: list::IntoAlpmListItem<'a, 'b>` is added only by the Drop impl.
   --> /home/andrej/.cargo/registry/src/github.com-1ecc6299db9ec823/alpm-1.1.8/src/list.rs:193:1
    |
193 | / impl<'a, T> Drop for AlpmListMut<'a, T>
194 | | where
195 | |     for<'b> T: IntoAlpmListItem<'a, 'b>,
196 | | {
...   |
208 | |     }
209 | | }
    | |_^
    |
note: The same requirement must be part of the struct/enum definition
   --> /home/andrej/.cargo/registry/src/github.com-1ecc6299db9ec823/alpm-1.1.8/src/list.rs:175:1
    |
175 | / pub struct AlpmListMut<'a, T>
176 | | where
177 | |     for<'b> T: IntoAlpmListItem<'a, 'b>,
178 | | {
179 | |     list: AlpmList<'a, T>,
180 | | }
    | |_^

error[E0367]: The requirement `for<'b> T: list::IntoAlpmListItem<'a, 'b>` is added only by the Drop impl.
   --> /home/andrej/.cargo/registry/src/github.com-1ecc6299db9ec823/alpm-1.1.8/src/list.rs:447:1
    |
447 | / impl<'a, T> Drop for IntoIterMut<'a, T>
448 | | where
449 | |     for<'b> T: IntoAlpmListItem<'a, 'b>,
450 | | {
...   |
453 | |     }
454 | | }
    | |_^
    |
note: The same requirement must be part of the struct/enum definition
   --> /home/andrej/.cargo/registry/src/github.com-1ecc6299db9ec823/alpm-1.1.8/src/list.rs:439:1
    |
439 | / pub struct IntoIterMut<'a, T>
440 | | where
441 | |     for<'b> T: IntoAlpmListItem<'a, 'b>,
442 | | {
443 | |     list: ManuallyDrop<AlpmListMut<'a, T>>,
444 | |     current: *mut alpm_list_t,
445 | | }
    | |_^

error: aborting due to 2 previous errors

For more information about this error, try `rustc --explain E0367`.
error: could not compile `alpm`.
warning: build failed, waiting for other jobs to finish...
error: build failed

yochananmarqos commented on 2021-04-01 23:37

@B28302: It means those packages neither exist in the Arch repos nor AUR. It appears you're using Manjaro and those packages were removed.

B28302 commented on 2021-04-01 22:47

What does this mean...

$ paru -Syu

:: Synchronizing package databases...

core is up to date

extra is up to date

community is up to date

multilib is up to date

:: Starting full system upgrade...

there is nothing to do

:: Looking for AUR upgrades

:: Looking for devel upgrades

:: Packages not in the AUR: linux-latest linux-latest-headers

there is nothing to do

Should the packages "linux-latest linux-latest-headers" be in AUR?

Why does it also say "Starting full system upgrade" (implying an action), yet "there is nothing to do" (no action)?

nainar commented on 2021-03-30 11:48

1.5.0 released https://github.com/Morganamilo/paru/commit/8835524f1d4c736e6e755563ac9798440212a1d0

Morganamilo commented on 2021-02-03 23:35

You're using an old rust version.

jstitch commented on 2021-02-03 18:15

When trying to update to paru v1.2.1-1 I'm getting the following messages during compilation:

error[E0658]: use of unstable library feature 'inner_deref': newly added --> src/upgrade.rs:294:29 | 294 | let remote = remote.as_deref().unwrap_or("devel"); | ^^^^^^^^ | = note: see issue #50264 https://github.com/rust-lang/rust/issues/50264 for more information

error[E0658]: use of unstable library feature 'inner_deref': newly added --> src/upgrade.rs:341:29 | 341 | let remote = remote.as_deref().unwrap_or("devel"); | ^^^^^^^^ | = note: see issue #50264 https://github.com/rust-lang/rust/issues/50264 for more information

error: aborting due to 2 previous errors

Seems a problem with Rust (?) I have two machines.

One has the rust package installed, paru updated succesfully.

The other one has rustup, so... perhaps there's some incompatibility here?

akiirui commented on 2021-01-30 20:51

Hello, I found a little problem. fish completion is installed to wrong place.

Should install to /usr/share/fish/vendor_completions.d/

Directories for third-party software vendors to ship their own completions for their software. Fish searches the directories in the XDG_DATA_DIRS environment variable for a fish/vendor_completions.d directory; if this variable is not defined, the default is usually to search /usr/share/fish/vendor_completions.d and /usr/local/share/fish/vendor_completions.d;

Ref: https://fishshell.com/docs/current/#where-to-put-completions

whynothugo commented on 2021-01-27 16:57

Odd. I can't really explain it. But it seems that zsh-completions should be added as an optional dependency.

0100001001000010 commented on 2021-01-27 16:51

@WhyNotHugo I did not have the zsh-completions package installed, although all other completions did work for me. Now that I installed zsh-completions by your suggestion, the completions for this package work too.