Package Details: paraview-salome 5.1.2plus-1

Git Clone URL: https://aur.archlinux.org/paraview-salome.git (read-only, click to copy)
Package Base: paraview-salome
Description: Parallel Visualization Application using VTK - This version is built to be linked against salome modules
Upstream URL: http://www.paraview.org
Licenses: custom
Conflicts: icet
Provides: paraview=5.1.2
Submitter: mickele
Maintainer: gbs
Last Packager: mickele
Votes: 9
Popularity: 0.000000
First Submitted: 2014-12-09 18:46
Last Updated: 2017-12-02 14:40

Dependencies (23)

Required by (10)

Sources (3)

Latest Comments

« First ‹ Previous 1 2

mickele commented on 2015-08-23 14:52

Added doxygen to makedepends

saxonbeta commented on 2015-08-21 12:28

Doxygen should be added to (I think) makedepends. Without it I get this error:
CMake Error at /usr/share/cmake-3.3/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)

mickele commented on 2015-03-10 22:09

Version 4.1.0-3 contains bug fixes in the installation procedure.

pychuang commented on 2015-02-25 22:18

When I first compiled this package, I encountered a problem related to a file called "/usr/share/openmpi/opal_wrapper-wrapper-data.txt". The message said "Error parsing data file opal_wrapper: Not found "

I found that file didn't exist, even though I had installed openmpi from Archlinux official repository.

No idea what happened. But I tried to use "make" to build each sub-package under paraview-salome separately. And I found the error occurred while building a sub-package called "SciberQuest". It seemed to happen when compiling some targets related to CUDA.

Anyway, I tried to make a file called "opal_wrapper-wrapper-data.txt" by myself based on the content in "mpiCC-wrapper-data.txt" and informations on the internet. And now the problem is solved. However, I still don't understand what happened.

My "opal_wrapper-wrapper-data.txt" looks like: https://www.dropbox.com/s/ud8s4u5y33d86xt/opalc%2B%2B-wrapper-data.txt?dl=0

mickele commented on 2015-01-21 17:19

Salome 7.4.0 requires paraview 4.1.0, so, please don't flag out-of-date this package. I'll update to 4.2.0 when salome 7.5 will be released.

mickele commented on 2015-01-21 17:17

Salome 7.4.0 requires paraview 4.1.0, so, pleasr don't flag outdated this package. I'll update to 4.2.0 when salome 7.5 will be released.

mickele commented on 2015-01-06 23:34

@noctlos
Try 4.1.0-2, I added a patch that should solve your issue.

mickele commented on 2015-01-06 21:25

@noctlos
Ok, I am working on a patch!

noctlos commented on 2015-01-06 18:23

[ 6%] Building CXX object VTK/Rendering/FreeType/CMakeFiles/vtkRenderingFreeType.dir/vtkFreeTypeTools.cxx.o
/tmp/yaourt-tmp/aur-paraview-salome/src/ParaView-v4.1.0/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx: In member function ‘bool vtkFreeTypeTools::Ca
lculateBoundingBox(const T&, vtkFreeTypeTools::MetaData&)’:
/tmp/yaourt-tmp/aur-builds/paraview-salome/src/ParaView-v4.1.0/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx:1190:51: error: no matching function for call to
‘min(unsigned int&, int&)’
metaData.descent);
^
This is the error that breaks the camel's back.