Package Details: papis 0.10-1

Git Clone URL: https://aur.archlinux.org/papis.git (read-only, click to copy)
Package Base: papis
Description: Papis is a powerful and highly extensible command-line based document and bibliography manager.
Upstream URL: https://github.com/papis/papis
Licenses: GPL
Submitter: JP-Ellis
Maintainer: JP-Ellis
Last Packager: JP-Ellis
Votes: 6
Popularity: 0.044058
First Submitted: 2018-08-13 20:42
Last Updated: 2020-05-20 11:38

Pinned Comments

JP-Ellis commented on 2019-12-23 02:27

The new release (0.9-2) includes two upstream patches that fixes compatibility issues with Arch Linux's Python packages.

Latest Comments

1 2 Next › Last »

JP-Ellis commented on 2020-02-20 03:37

@johnabs The convention is that pkgname should track the latest released version while pkgname-git tracks master. Having said that, I will consider including patches for certain bugs (usually specific to Arch Linux), and will do so by including the commit patches from upstream. General fixes/improvements that are part of the usual software development will usually not be included.

For example, the two patch files currently included have been pushed upstream and will be included in the next release, but were only of relevance for Arch Linux (hence why you noticed they are no longer necessary for this newer version).

You are quite welcome to create your own papis-git AUR package, meanwhile, I will wait until the next official release of papis (which will hopefully arrive sooner rather than later).

Thanks for pointing out the missing python-stevedore. I will add it to the PKGBUILD.

johnabs commented on 2020-02-20 02:37

@JP-Ellis,

There's a new update in master that Alex and Ale helped me get working with the bug where this hangs after using the picker. Also, there are 2 missing dependencies (python-stevedore, and python-typing_extensions(the latter required for the new commit, it would seem). Additionally, it seems that the two patches that are present are no longer necessary for this newer version. I have an updated PKGBUILD that addresses these issues and pulls from the master branch by default. Would it be more appropriate to create this build I've worked on as a papis-git pkg, or would you like a copy of this updated version to update this particular pkg? (Sorry, I hope this doesn't come off as rude, I'm a bit new to AUR etiquette) Thank you for your time and consideration.

--johnabs

jtlab commented on 2019-12-23 08:24

@JP-Ellis It works now, thanks for your reply.

Just to make sure, so I know what the issue was: you mean reinstall all AUR packages, but there was only papis in site packages. The command you posted also only included papis.

Do I have any control over where the package is installed, or do these python compatiblity issues need to be resolved by package maintainers only?

JP-Ellis commented on 2019-12-23 02:34

@jtlab When there's a major Python update (Python 3.7 -> 3.8), you have to re-install all AUG packages. Until you have done so, you will still have packages in /usr/lib/python3.7). There were some incompatibilities with papis 0.9 which I have now fixed, so perhaps you still had papis in python3.7 simply because it failed to install correctly. It installs correctly into /usr/lib/python3.8 for me now.

In case you need to check for other packages with Python 3.8, you can get a list of all packages which with:

find /usr/lib/python3.7 -exec pacman -Qoq '{}' + | sort -u

JP-Ellis commented on 2019-12-23 02:27

The new release (0.9-2) includes two upstream patches that fixes compatibility issues with Arch Linux's Python packages.

jtlab commented on 2019-12-16 21:26

When I install this package with yay, the papis module is installed into /usr/lib/python3.7/site-packages/papis. I have python 3.8 installed though.

Oddly, all dependencies are installed into /usr/lib/python3.8/site-packages/. My /usr/lib/python3.7/site-packages folder only contains papis and papis-0.9-py3.7.egg-info after install.

Of course this leads to the following error:

The 'papis==0.9' distribution was not found and is required by the application

When I manually copy both dirs (papis and papis-0.9-py3.7.egg-info) from /usr/lib/python3.7/site-packages to /usr/lib/python3.8/site-packages, papis works as expected.

I cloned the official papis github repos to test installing papis from source into user space using the following command derived from the PKGBUILD file: python setup.py build && python setup.py install --user --optimize=1 --skip-build. The papis module will be installed in .local/lib/python3.8/site-packages.

Since it never happens with installation through pip or setuptools, I assume there is something wrong with this package. My apologies in advance if I am wrong.

JP-Ellis commented on 2019-12-02 22:23

@BrainDamange Apologies for the mishap with the upgrade to 0.9. There is actually an ongoing issue with upper limits on dependencies. I have created an issue and pull request upstream (https://github.com/papis/papis/issues/242) and I will update papis then. In the meantime, I'm going to revert back the upgrade on AUR.

BrainDamage commented on 2019-12-02 22:01

the package is missing the following deps: python-doi python-stevedore

thoth101010 commented on 2018-11-21 18:55

Thank you for your advice, now python-prompt_toolkit is up-to-date.

It seems that python-parse is also required by papis.

( and setup.py wants outdated versions of python-slugify and python-click )

JP-Ellis commented on 2018-11-14 01:26

@darehanl Thanks for the feedback. I've updated the dependencies to reflect exactly what's in setup.py. I've made the changes in the latest version (0.7.4). For earlier versions, you'll have to modify the PKGBUILD yourself unfortunately.