Package Details: pango-legacy 1.44.1-2

Git Clone URL: https://aur.archlinux.org/pango-legacy.git (read-only, click to copy)
Package Base: pango-legacy
Description: A library for layout and rendering of text. This is the latest supported version without harfbuzz version error (Harfbuzz version too old (1.4.2))
Upstream URL: https://pango.gnome.org
Licenses: LGPL
Submitter: ValHue
Maintainer: ragouel
Last Packager: ragouel
Votes: 0
Popularity: 0.000000
First Submitted: 2019-11-18 18:31
Last Updated: 2020-05-19 15:02

Latest Comments

naruto522ru commented on 2020-04-06 00:14

@ValHue Well, no need to refuse service. Let it be you just do not update it, that's all. Everything works great. With my package, which I support vryatli, something will change because the developers no longer release updates, but as for the only thing, I would argue this is not yet. Then it will be. By the way, you can still solve the problem differently from someone due to pango error. Put not your package, but pango-ubuntu then the problem is also solved, but I chose your package because there are a lot of dependencies and makedepends there to build pango-ubuntu.

ValHue commented on 2020-04-01 08:36

This package was made to satisfy the dependency of some applications that have not been adapted to the new version of pango. Specifically wp-desktop, which now no longer needs it. Fewer and fewer programs depend on it, officially one rto-proxy-bin.

On the other hand, the problems discussed by svinto, I have no idea why they happen. Since it happens when it has to show texts the same is some dependency with some font ... I honestly don't know.

It is for all this that I am going to abandon its maintenance, anyone who is interested can adopt it.

@naruto522ru, you may be interested since you keep rto-proxy-bin

naruto522ru commented on 2020-03-31 16:36

@ValHue What is the problem, can I help solve it? Have problems with wp-desktop?

ValHue commented on 2020-03-31 09:18

Well I have no idea how to fix it.. :(

naruto522ru commented on 2020-03-31 06:48

@ValHue I will also thank you!

svinto commented on 2020-03-30 19:56

@ValHue Thank you for the input, but I get the same problem with wp-desktop. I will write again if I figure something out.

ValHue commented on 2020-03-30 18:08

@svinto: I put the full path to the application executable. Look at the PKGBUILD of wp-desktop as an example. And in this case it doesn't give me any problem.

svinto commented on 2020-03-30 17:58

Thanks greatly for this package. Though when using this with electron apps that can open a file browser, text in said file browser are not displayed properly (all letters are represented by squares).

How I use this package: LD_LIBRARY_PATH=/opt/pango-legacy/usr/lib APP_NAME

I have confirmed this problem with https://github.com/zz85/space-radar/releases (SpaceRadar-linux-x64.zip) and toa (in AUR).

Any idea if I am doing something wrong, or how to fix it?