Package Details: panda3d 1.10.8-4

Git Clone URL: https://aur.archlinux.org/panda3d.git (read-only, click to copy)
Package Base: panda3d
Description: A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
Upstream URL: http://www.panda3d.org
Keywords: engine game
Licenses: BSD
Submitter: wonder
Maintainer: AndyMender
Last Packager: AndyMender
Votes: 40
Popularity: 0.027782
First Submitted: 2010-01-30 22:41
Last Updated: 2021-01-04 20:35

Dependencies (37)

Required by (3)

Sources (3)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 Next › Last »

vdust commented on 2011-12-04 00:53

bison and flex are mandatory build dependencies and should be added in makedepends.

Anonymous comment on 2011-11-29 16:47

@Tarinaky
I have no idea. For my builds I either disable fmod with --no-fmodex (added like makepanda.py --everything --no-fmodex) or simply uninstall it. OpenAL is enough for most aplications and it's free. It's the default audio library in Panda, by the way.

Anonymous comment on 2011-11-29 07:15

Is there a package for the fmodex version that will work with this PKGBUILD?

Anonymous comment on 2011-10-09 17:13

Both bison and flex are parts of the group "base-devel" which you are expected to have installed before making your own packages.
For the conflict, you can either force overriding the file with "pacman -Sf package" or add a line to the PKGBUILD that removes or renames the file. When Panda 1.8 comes out and this file will be still there, I'll rename it.

Anonymous comment on 2011-10-09 10:58

To make a package I have to install flex and bison. Should they be add to depends i PKGBUILD? I have also problem with install package. Pacman told me that is conflict of file, file /usr/bin/bin2c exist.

sftrytry commented on 2011-09-03 03:01

updated
I downgraded fmodex back to 4.32, and panda3d got compiled.

sftrytry commented on 2011-09-02 15:45

I got these errors. It seems to have some thing to do with fmodex package. I found that there was an update of fmodex form 4.32.7 to 4.36. Those macros are defined in 4.32 but not in 4.36
[ 36%] Building C++ object built/tmp/fmod_audio_fmod_audio_composite.o
In file included from panda/src/audiotraits/fmod_audio_composite1.cxx:3:0,
from panda/src/audiotraits/fmod_audio_composite.cxx:1:
panda/src/audiotraits/fmodAudioManager.cxx: In member function ‘FMOD::DSP* FmodAudioManager::make_dsp(const FilterProperties::FilterConfig&)’:
panda/src/audiotraits/fmodAudioManager.cxx:306:28: error: ‘FMOD_DSP_REVERB_DRYMIX’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:307:28: error: ‘FMOD_DSP_REVERB_WETMIX’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:308:28: error: ‘FMOD_DSP_REVERB_ROOMSIZE’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:309:28: error: ‘FMOD_DSP_REVERB_DAMP’ was not declared in this scope
panda/src/audiotraits/fmodAudioManager.cxx:310:28: error: ‘FMOD_DSP_REVERB_WIDTH’ was not declared in this scope
Storing dependency cache.

Anonymous comment on 2011-08-22 13:09

Done. Thanks for the note.

Anonymous comment on 2011-08-21 12:11

Ooops, sorry for that. Will fix that ASAP.

flecha commented on 2011-08-20 12:37

Hi Nemesis#13!
Looks like there is a problem with the deps. There is a '' (empty dep), so it can't install because it doesn't find program ''. =P