Package Details: panda3d 1.10.8-4

Git Clone URL: https://aur.archlinux.org/panda3d.git (read-only, click to copy)
Package Base: panda3d
Description: A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
Upstream URL: http://www.panda3d.org
Keywords: engine game
Licenses: BSD
Submitter: wonder
Maintainer: AndyMender
Last Packager: AndyMender
Votes: 40
Popularity: 0.21
First Submitted: 2010-01-30 22:41
Last Updated: 2021-01-04 20:35

Dependencies (37)

Required by (3)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

abhisheietk commented on 2016-03-20 13:17

while compilation getting this error

panda/src/ffmpeg/ffmpegVideoCursor.cxx:94:33: error: 'PIX_FMT_BGR24' was not declared in this scope
PIX_FMT_BGR24, SWS_BILINEAR | SWS_PRINT_INFO, N

croxis commented on 2015-04-11 16:27

Note: there is experimental python3 support. Edit PKGBUILD to use python or python3

bkfox commented on 2014-04-06 12:07

Please, avoid the default 4 and 5 threads at build. Perhaps is it better to use nproc to select a number of threads corresponding to the number of cpu's cores.

Anonymous comment on 2014-04-03 21:19

http://pastebin.com/pneJxbfc

croxis commented on 2014-02-11 21:03

Updated. Thanks.

2M1R commented on 2014-01-10 14:36

This is my pkgbuild with patch for panda_glxext.h and with freeglut dependency: http://www.sendspace.com/file/cca9tm

gadget3000 commented on 2014-01-08 19:12

I think this requires freeglut as a dependency. Without it I get the following error when building bullet:
In file included from /tmp/yaourt-tmp-gadget/aur-panda3d/src/panda3d-1.8.1/bullet/src/BulletMultiThreaded/GpuSoftBodySolvers/OpenCL/btSoftBodySolverOutputCLtoGL.cpp:5:0:
/tmp/yaourt-tmp-gadget/aur-panda3d/src/panda3d-1.8.1/bullet/src/BulletMultiThreaded/GpuSoftBodySolvers/OpenCL/btSoftBodySolverVertexBuffer_OpenGL.h:51:21: fatal error: GL/glut.h: No such file or directory
#include <GL/glut.h>
^
compilation terminated

croxis commented on 2013-04-15 17:08

I took over maintaining panda3d. This is the first time I ever maintained a package for any linux distro. Forgive the dumb moments I may have.

I've included Vixus' bullet build script. ODE is still not supported.

corro commented on 2013-03-22 12:36

Bump to 1.8.0-11.
Changes:
- Added --no-gles2 argument as PyroDevil suggested (thanks for the hint)

I'm orphaning this package since I'm no longer actively using it. Feel free to adopt it again.

PyroDevil commented on 2013-03-21 19:35

You need to add --no-gles2, because otherwise the build will fail.