Package Details: panda3d 1.10.8-4

Git Clone URL: https://aur.archlinux.org/panda3d.git (read-only, click to copy)
Package Base: panda3d
Description: A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
Upstream URL: http://www.panda3d.org
Keywords: engine game
Licenses: BSD
Submitter: wonder
Maintainer: AndyMender
Last Packager: AndyMender
Votes: 40
Popularity: 0.45
First Submitted: 2010-01-30 22:41
Last Updated: 2021-01-04 20:35

Dependencies (37)

Required by (3)

Sources (3)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ilikepickles commented on 2021-03-05 09:14

I'm using cmake for this build.

I tried making those changes to the headers but I went too far and found myself making changes inside the freetype library and since I had exceeded my skill envelope I bravely gave up.

AndyMender commented on 2021-03-04 21:01

In the end I installed the Conan freetype package and I'm able to build.

Glad to hear, but consuming the header without having to use an external package manager should still work.

The line should be #include <freetype2/ft2build.h> rather than #include <ft2build.h> as the common include directory is /usr/include. The alternative is to make sure your compile target includes also /usr/include/freetype2. This looks more like a bug to me.

Which build system are you using? Raw make, cmake, qmake or something else?

ilikepickles commented on 2021-03-04 16:40

In the end I installed the Conan freetype package and I'm able to build.

ilikepickles commented on 2021-03-04 15:51

Hello maintainer... When attempting to include panda3d's dynamicTextFont.h my project fails to build because it can't find #include <ft2build.h> although I do have libfreetype2 installed and the header is in usr/include/freetype2/ft2build.h. Any thoughts on the right approach to resolving this? If I change the panda3d headers (in freeTypeFace.h, dynamicTextFont.h and freeTypeFace.h) I start getting build errors from inside the freetype headers. So before I shredded my whole /usr/include directory I thought I'd get your advice. :-) Cheers

AndyMender commented on 2020-12-29 09:36

@rdb Updated to 1.10.8. Thanks for the heads-up! :)

EDIT: I also improved the depends and optdepends listing a bit.

jose1711 commented on 2020-12-25 15:26

@Nullrequest @xyproto @nerdnils should be fixed in panda3d 1.10.7-2

jsgrant commented on 2020-12-10 20:12

Currently this package (using v1.10.7) fails to build if you have Bullet Physics already installed. I've been told this is due to API changes between Bullet 2.9.x and 3.x -- which have been resolved upstream. Building the Git version of this package (panda3d-git) seems to compile / work as expected.

Nullrequest commented on 2020-09-25 08:59

I am unable to install panda3d. Every time I get a error stating panda3d: /usr/lib64 exists in filesystem (owned by filesystem) I am not sure what to do how should i fix this?

xyproto commented on 2019-05-18 09:42

Beware: If /usr/lib64 is replaced or removed, Arch Linux may stop booting after a kernel upgrade.

croxis commented on 2019-01-19 02:25

I don't think that will work as desired, but I started a python2 AUR here: https://aur.archlinux.org/packages/panda3d-python2