Package Details: panda3d-runtime 1.0.4-1

Git Clone URL: https://aur.archlinux.org/panda3d-runtime.git (read-only)
Package Base: panda3d-runtime
Description: 3D engine with Python bindings. Runtime and web plugin.
Upstream URL: http://www.panda3d.org
Licenses: BSD
Submitter: None
Maintainer: croxis
Last Packager: croxis
Votes: 4
Popularity: 0.000020
First Submitted: 2010-03-02 20:13
Last Updated: 2015-06-17 19:39

Latest Comments

croxis commented on 2015-04-11 16:25

I can replicate the error, I forward it upstream.
Use panda3d-runtime-git. It works: https://aur.archlinux.org/packages/panda3d-runtime-git/

qubodup commented on 2015-04-11 06:52

I'm getting this error trying to compile unfortunately: http://codepad.org/5xJup3gL

jgabrito commented on 2014-07-10 21:41

I get some errors regarding the declarations of some functions such as fork(), unlink(), as well as a few others when trying to build. The following patch solves it:

http://bpaste.net/raw/452157/

Anonymous comment on 2012-03-19 23:52

The official release doesn't build, but you can try the cvs version. It works for me.

Anonymous comment on 2011-05-22 19:12

Woops, you're right, silly me. Update incoming

Anonymous comment on 2011-05-22 13:43

Wow, thanks Tucos. Great job.

I'm only missing the install file. Shouldn't it be listed within the sources?

Anonymous comment on 2011-05-22 12:01

Updated the package, changed the following things:
- Split build() and package()
- Put libs in the proper place for x86_64
- Fixed depends and makedepends
- Fixed the arch array
- Added an install file to update the mime stuff

Most of the changes were suggestions from namcap. Just noticed I probably should not recreate the symlinks for i686, although doing so won't hurt :p

Anonymous comment on 2010-05-19 03:19

Oh and to the dependencies: are you sure that it requires them all? You should know that makepanda prints every dependency it can't find, required or optional.

Anonymous comment on 2010-05-19 03:17

Thanks for the coment, but this package doesn't build anyway for me. Most probably due to buggy zlib and new OpenSSL 1.0.
Same for CVS checkouts :-(

Does it work for you?

eyecreate commented on 2010-05-18 22:47

requires these packages too:
OpenSSL, TinyXML, ZLib, NPAPI, JPEG, X11 and PNG