Package Details: pam-python 1.0.7-1

Git Clone URL: https://aur.archlinux.org/pam-python.git (read-only, click to copy)
Package Base: pam-python
Description: Python for PAM
Upstream URL: https://github.com/boltgolt/howdy
Licenses: MIT
Submitter: kageurufu
Maintainer: kageurufu (boltgolt)
Last Packager: kageurufu
Votes: 3
Popularity: 0.94
First Submitted: 2019-10-24 16:27
Last Updated: 2020-12-03 16:13

Latest Comments

renyuneyun commented on 2020-11-28 11:07

The new version (1.0.8) changes its source and therefore can be built without Python2 (and python2-sphinx). The prepare() function in PKGBUILD no longer need to replace all Python with Python2, at least during my build. Basically, I did the following steps:

  1. update to v1.0.8
    1. update package version to 1.0.8 (line 4)
    2. replace source with newer version (line 18)
    3. update the hash (I actually used 'SKIP') (line 20)
  2. remove everything about python 2, and replace with python 3 where necessary
    1. comment out dependency of python2 (line 11)
    2. replace make dependency python2-sphinx with python-sphinx (line 14)
    3. comment out (in prepare()) lines replacing python with python2, as well as sphinx (line 25, 26 & 28)

lgaboury commented on 2020-11-12 20:54

Will not install as the python2-sphinx package it depends on is no longer available.

xuanruiqi commented on 2019-11-19 04:29

Don't forget to update .SRCINFO ;-)

uumas commented on 2019-11-16 20:22

You forgot to update .SRCINFO with the 1.0.7 update.