Package Details: palm-novacom-git 20130426-1

Git Clone URL: https://aur.archlinux.org/palm-novacom-git.git (read-only, click to copy)
Package Base: palm-novacom-git
Description: WebOS <-> PC connection, open source version
Upstream URL: http://openwebosproject.org/
Licenses: Apache
Conflicts: palm-novacom
Provides: palm-novacom
Submitter: t-8ch
Maintainer: t-8ch
Last Packager: t-8ch
Votes: 43
Popularity: 0.000000
First Submitted: 2012-04-11 17:07
Last Updated: 2015-07-06 06:09

Latest Comments

1 2 3 4 5 Next › Last »

benklop commented on 2020-10-30 05:27

There are linker issues at present; this patch fixes it:

diff --git a/CMakeLists.txt b/CMakeLists.txt
index babc1fe..65653d3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,8 +27,8 @@ webos_component(2 0 0)
 webos_machine_impl_dep()

 add_definitions(-DBUILDVERSION="${WEBOS_COMPONENT_VERSION}")
-webos_add_compiler_flags(ALL -DPLATFORM_PTHREADS=1)
-webos_add_compiler_flags(ALL -Wall -g -O2)
+webos_add_compiler_flags(ALL -DPLATFORM_PTHREADS=1 -Xlinker -z -Xlinker muldefs)
+webos_add_compiler_flags(ALL -Wall -g -O2 -Xlinker -z -Xlinker muldefs)

 include_directories(include)

Anonymous comment on 2016-05-06 00:49

This needs git in the makedepends array.

t-8ch commented on 2013-01-04 12:16

The problem isn't makepkg, but AUR helpers like yaourt.
Anyways I changed the dependency.

ManceRayder commented on 2013-01-04 02:11

i am running into the same issue. is there a way to get makepkg to recognize cmake-modules-webos-git as the same dependency?

t-8ch commented on 2013-01-01 00:36

Yeah, the package is called cmake-modules-webos-git and it provides cmake-modules-webos.

Anonymous comment on 2012-12-31 18:51

requires cmake-modules-webos currently to install, which it says is in AUR but yaourt / I can't find

t-8ch commented on 2012-12-29 11:45

Should work again, please report further bugs :-)

joshgillies commented on 2012-12-29 06:44

Changes upstream mean that the patches here don't apply currently.

wiliam commented on 2012-09-29 15:57

Disowned in favor of palm-novacom-git package.

ryanc commented on 2012-08-27 18:17

Please use palm-novacom-lite going forward.