Package Details: pacserve 2021-1

Git Clone URL: https://aur.archlinux.org/pacserve.git (read-only, click to copy)
Package Base: pacserve
Description: Easily share Pacman packages between computers. A replacement for PkgD.
Upstream URL: https://xyne.archlinux.ca/projects/pacserve
Keywords: arch_linux pacman server
Licenses: GPL
Conflicts: pacredir
Submitter: Xyne
Maintainer: Xyne
Last Packager: Xyne
Votes: 103
Popularity: 0.44
First Submitted: 2011-04-17 00:30
Last Updated: 2021-02-11 12:51

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

olive commented on 2018-08-22 18:17

@Mouath I have tried to rebuild both packages but the error remain. You will see that the unit status is "restarting" (systemctl list-units) and the crash log from python can be see in the journal (journalctl). Have you tried with an up to date system (the error is recent, it used to work).

Update: I had ipv6 disabled (because I don't use it). The error seems to disappear if I enable it. Don't know why it must be enabled.

Mouath commented on 2018-08-21 19:56

@olive you need to rebuild manually

yaourt -S python3-threaded_servers pacserve

olive commented on 2018-08-19 16:22

Seems to be broken. Probably due to a bug in pacserve, see the comment I made on this package: https://aur.archlinux.org/packages/python3-threaded_servers/

Plexcon commented on 2018-05-22 12:09

1. gpg --keyserver pgp.mit.edu --recv-key 1D1F0DC78F173680

sudo pacman-key --lsign 1D1F0DC78F173680

2.Install: python3-threaded_servers (AUR) + pyalpm (extra repository) + pacserve (AUR)

knedlyk commented on 2018-05-04 09:37

@skystrife I confirm this. But I had to uninstall completely and then install python3-threaded_servers. Silmply reinstall didn't work.

skystrife commented on 2018-05-01 21:11

My issue seems resolved for me by upgrading to python3-threaded_servers 2018.4.28-1.

craftyguy commented on 2018-04-29 19:04

I am also having the same problem that @mareex reported

skystrife commented on 2018-04-27 20:35

Similar problem on my end. I get an endless list of the following three lines until I kill the pacman process (seems to be redirecting to itself in an endless loop):

Apr 27 14:27:07 arturia pacserve[1428]: [2018-04-27 14:27:07 CDT] INFO: 127.0.0.1 "GET /pacman/core/x86_64/core.db HTTP/1.1" 303 -
Apr 27 14:27:07 arturia pacserve[1428]: [2018-04-27 14:27:07 CDT] INFO: 127.0.0.1 redirecting to http://localhost:15678/pacman/core/x86_64/core.db
Apr 27 14:27:07 arturia pacserve[1428]: [2018-04-27 14:27:07 CDT] INFO: 127.0.0.1 tell the Pacman devs to url-decode their redirects

mareex commented on 2018-04-27 19:32

cannot update my system anymore after upgrading to 2018-8. Pacman is stuck and I have a process called "python3 -mThreadedServers.Pacserve --multicast" eating a lot of cpu.

oksijun commented on 2018-04-26 17:42

python-dbus seems to be a mandatory dependency now ? pacserve refused to start without it