Package Details: package-query-git 1.12.r0.g840a000-1

Git Clone URL: https://aur.archlinux.org/package-query-git.git (read-only, click to copy)
Package Base: package-query-git
Description: Query ALPM and AUR
Upstream URL: https://github.com/archlinuxfr/package-query
Licenses: GPL
Conflicts: package-query
Provides: package-query=1.12
Submitter: tuxce
Maintainer: archlinuxfr (Skunnyk, f2404)
Last Packager: f2404
Votes: 149
Popularity: 0.006809
First Submitted: 2010-03-15 13:14
Last Updated: 2021-06-02 15:22

Dependencies (3)

Required by (7)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Freso commented on 2016-03-13 21:49

You should really consider using one a pkgver() based off of one of the ones at https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function - right now the latest package-query-git resolves to "1.8.13.g8ad832f-1", which means that it would show up as being more recent than a theoretical 1.8.1 being released a month from now. All the ones on the wikipage adds an "r" before the number of revisions since last tag.

(I would also personally make the $provides dynamic so it provides whatever version gets set with pkgver(). Means that part doesn't have to be updated once 1.9 is tagged.)

f2404 commented on 2016-01-08 14:47

@mokkurkalve
Thanks for reporting it!
The issue has been resolved under this pull request: https://github.com/archlinuxfr/package-query/pull/64

mokkurkalve commented on 2016-01-07 01:47

Suddenly, after installing version 1.7.80.gb2a07fe-1, I'm missing newlines between packages in the output of:
package-query -QAm
Looks strange now..... are this intended...?

rcct commented on 2014-12-29 19:34

@tuxce

Just wanted to be sure about the steps to follow. I rebuilt the package and all is back to normal now.

As for the PKGBUILD not needing a change, shouldn't at least the package relation be updated to 2 to concord with the package-query one?

tuxce commented on 2014-12-29 19:14

You just need to rebuild it, the PKGBUILD doesn't need to change.
The link with libs is made on build time, so if you built it when you had libalpm.8, you have to redo it after installing pacman 4.2 which provides libalpm.9

rcct commented on 2014-12-29 19:13

Any hint on managing the libalpm update with the git version?

The non git one has been update as far as I have checked (even its PKGBUILD) though this one does seem to lack behind...

rcct commented on 2014-12-29 19:06

Any hint on managing the libalpm update with the git version?

The non git one has been update as far as I have checked (ven its PKGBUILD) though this one does seem to lack behind...

anish commented on 2014-12-23 09:14

Problem still persists. starnostar's PKGBUILD works fine however.

starnostar commented on 2014-12-19 06:41

fixed PKGBUILD for 1.4-2

https://gist.github.com/starnostar/d0b2a1370e638084f422

mokkurkalve commented on 2014-12-18 16:24

One wrong symlink fix yes. Thanks!