Package Details: package-query-git 1.12.r0.g840a000-1

Git Clone URL: https://aur.archlinux.org/package-query-git.git (read-only, click to copy)
Package Base: package-query-git
Description: Query ALPM and AUR
Upstream URL: https://github.com/archlinuxfr/package-query
Licenses: GPL
Conflicts: package-query
Provides: package-query=1.12
Submitter: tuxce
Maintainer: archlinuxfr (Skunnyk, f2404)
Last Packager: f2404
Votes: 149
Popularity: 0.006350
First Submitted: 2010-03-15 13:14
Last Updated: 2021-06-02 15:22

Dependencies (3)

Required by (7)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

f2404 commented on 2021-06-02 15:24

New version has been released.

warp4ever commented on 2021-06-01 21:16

Not working: alpm-query.c:74:9: warning: implicit declaration of function ‘alpm_option_set_arch’; did you mean ‘alpm_option_set_dlcb’? [-Wimplicit-function-declaration] 74 | alpm_option_set_arch (handle, config.arch); | ^~~~~~~~~~~~~~~~~~~~ | alpm_option_set_dlcb alpm-query.c: In function ‘parse_config_server’: alpm-query.c:96:28: warning: implicit declaration of function ‘alpm_option_get_arch’; did you mean ‘alpm_option_get_dlcb’? [-Wimplicit-function-declaration] 96 | const char arch = alpm_option_get_arch (config.handle); | ^~~~~~~~~~~~~~~~~~~~ | alpm_option_get_dlcb alpm-query.c:96:28: warning: initialization of ‘const char ’ from ‘int’ makes pointer from integer without a cast [-Wint-conversion] alpm-query.c: In function ‘search_pkg’:

alpm-query.c:397:29: error: too few arguments to function ‘alpm_db_search’ 397 | alpm_list_t pkgs = alpm_db_search (db, targets); | ^~~~~~~~~~~~~~ In file included from util.h:23, from alpm-query.c:28: /usr/include/alpm.h:1413:5: note: declared here 1413 | int alpm_db_search(alpm_db_t db, const alpm_list_t needles, | ^~~~~~~~~~~~~~ make[2]: [Makefile:429: alpm-query.o] Error 1 make[2]: Leaving directory '/home/XXX/.cache/yay/package-query-git/src/package-query/src' make[1]: [Makefile:409: all-recursive] Error 1 make[1]: Leaving directory '/home/XXX/.cache/yay/package-query-git/src/package-query' make: ** [Makefile:341: all] Error 2 ==> ERROR: A failure occurred in build().

f2404 commented on 2017-07-20 02:00

@fightcookie Done, thanks!

xuiqzy commented on 2017-07-20 01:50

please change URL to the TLS encrypted https version, tested it and works fine! thanks :)

f2404 commented on 2016-06-16 09:48

@Prototik, done.

Prototik commented on 2016-06-14 11:02

Please add aarch64 architecture to supported, as it provided in package-query package.

idiotbox commented on 2016-04-20 14:32

@f2404 Hi,

Yes, you're right. Found out that I forgot to install base-devel.
Thank for the reply.

f2404 commented on 2016-04-20 05:41

Hi @idiotbox,
no, they shouldn't be stated in PKGBUILD - see https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

Please check whether the build issue persists after following the instructions.

idiotbox commented on 2016-04-19 20:27

Getting the following error while building.

checking for alpm_version in -lalpm... yes
./configure: line 12045: syntax error near unexpected token `alpm,'
./configure: line 12045: `PKG_CHECK_MODULES(alpm, libalpm >= 10.0.0)'
==> ERRO: Uma falha ocorreu em build().
Abortando...

Just did a Arch fresh install, and it seems that there are a lot of buildeps not present in PKGBUILD, like make, gcc, autoconf. souldn't they be present?

Skunnyk commented on 2016-03-20 16:34

@Fresco : yes, you are right. Updated to use correct pkgver variable.