Package Details: pacgui 13.50a4429-1

Git Clone URL: https://aur.archlinux.org/pacgui.git (read-only, click to copy)
Package Base: pacgui
Description: System updates with a simple pacman GUI, based on Zenity
Upstream URL: https://gitlab.com/it-me/pacgui
Keywords: GUI pacman
Licenses: GPLv3
Submitter: sgar
Maintainer: sgar
Last Packager: sgar
Votes: 2
Popularity: 0.37
First Submitted: 2020-07-27 20:53
Last Updated: 2020-07-28 20:31

Latest Comments

sgar commented on 2021-06-11 21:07

@Andy_Vetrov, it was a design decision to not ask for credentials, have a look at: https://gitlab.com/it-me/pacgui#recommendation

Andy_Vetrov commented on 2021-06-06 18:01

Thank you for a great idea S Gar! But can you change pacgui.sh, because password promt not work correctly at this time?

if [ $? -eq 0 ]; then
        echo "Upgrade st#!/bin/bash

pacman_error () {
zenity --error --text="Error: $1"
killall zenity
exit 
}

updates=$(checkupdates)
if [ $? -eq 0 ]; then

    zenity --info --width=400\
          --text="Packages to update:\n$(echo "$updates" | awk '{if(FNR <= 10) {print $1} }')"

    zenity --question \
    --text="Do yout want to continue with the updates?" --width=400

    if [ $? -eq 0 ]; then
        echo "Upgrade started!"
        (
            PASSWD="$(zenity --password --title=Authentication)\n"
            echo "10" ; sleep 1
            echo "# Sync Databases" 
            echo "30" ; echo -e $PASSWD | nice -15 sudo -S pacman -Syy --noconfirm || pacman_error "Sync"
            echo "# Downloading Packages" ; sleep 1
            echo "60" ; nice -15 sudo -S pacman -Syw --noconfirm || pacman_error "Download"
            echo "# Installing updates" ; sleep 1
            echo "80" ; nice -15 sudo -S pacman -Syu --noconfirm || pacman_error "Update"
            echo "# Finished with the updates"
            echo "100"
        ) |
        zenity --progress \
          --title="System Update" \
          --text="Databases will be updated …" \
          --percentage=0 --width=400 || pacman_error

    elif [ $? -eq 1 ]; then
        echo "Upgrades stopped!"
    else
        echo "An unexpected error was encountered."
    fi

else
    zenity --info --text="No updates available." --width=400 
    exit
fi

This variant works flawless for me.