Package Details: otf-inconsolata-powerline-git r202.e80e3eb-1

Git Clone URL: https://aur.archlinux.org/otf-inconsolata-powerline-git.git (read-only, click to copy)
Package Base: otf-inconsolata-powerline-git
Description: Inconsolata for Powerline
Upstream URL: https://github.com/powerline/fonts
Licenses: OFL
Conflicts: otf-inconsolata-powerline, powerline-fonts, powerline-fonts-git
Provides: otf-inconsolata-powerline
Submitter: Archer777
Maintainer: caleb (quixoten)
Last Packager: caleb
Votes: 22
Popularity: 0.000044
First Submitted: 2013-03-05 12:23
Last Updated: 2020-08-22 09:35

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

caleb commented on 2020-08-22 09:39

@quixoten I added you as a co-maintainer since I see you requested the orphan process as well. I already overhaulled this package so it should be good to go, I see you have a whole pile of packages that need the same changeset. Maybe have a review at all the things I changed (License field, drop install, tweak conflicts, drop dependencies, simplify scripting, use re-usable source checkout, etc.

caleb commented on 2020-08-08 12:25

Re this from @oteblan:

Please add xorg-bdftopcf xorg-mkfontdir xorg-mkfontscale xorg-font-util to the dependencies.

No! Please don't add anything to the dependencies. Font packages for the most part shouldn't have any dependencies at all, and this is not an exception. Please see the font packaging guidelines on the wiki, but all the dependencies (expect the makedepends) should be removed from this package. Also the license field should be just license=('OFL'), also see the wiki.

otreblan commented on 2020-07-02 16:39

@quixoten xorg-font-utils has been deleted. Please add xorg-bdftopcf xorg-mkfontdir xorg-mkfontscale xorg-font-util to the dependencies.

Archer777 commented on 2015-01-03 07:53

@quixoten Sure go ahead. You can also take over other powerline-font packages maintained by me.

quixoten commented on 2014-12-17 21:31

Sial, would you mind if I take-over maintenance of this package? I'm maintaining a number of other powerline-font packages (https://aur.archlinux.org/packages/?SeB=m&K=quixoten) and am attempting to resolve some of the conflicts that exist with the powerline packages in the AUR.

howardad commented on 2014-08-19 21:59

I'm having 2 minor problems with this PKGBUILD. First, it is missing the AUR metadata, which makes pacaur complain. Second, the lack of a pkgver() function means that this package is rebuilt and installed every time I check for AUR updates as pacaur (or makepkg?) thinks that the current version is today's date and the installed version is the date listed in the PKGBUILD (20130604, I think). Just little irritations, so fix them when you can. Thanks!

Archer777 commented on 2013-05-22 03:24

Updated PKGBUILD to reflect the changes in pacman 4.1.