Package Details: otf-droid-sans-mono-powerline-git r100.a44abd0-2

Git Clone URL: https://aur.archlinux.org/otf-droid-sans-mono-powerline-git.git (read-only, click to copy)
Package Base: otf-droid-sans-mono-powerline-git
Description: Droid Sans Mono for Powerline
Upstream URL: https://github.com/powerline/fonts
Licenses: custom:Apache License, Version 2.0
Conflicts: powerline-fonts, powerline-fonts-git
Submitter: quixoten
Maintainer: quixoten
Last Packager: quixoten
Votes: 3
Popularity: 0.000000
First Submitted: 2014-12-17 21:21
Last Updated: 2016-02-03 17:34

Latest Comments

quixoten commented on 2016-06-06 02:32

Thanks for the feedback AG_Caesar. Make sure you are using "otf" to start the package name. Your error indicates "ttf". I think if you change it to "otf" you'll be back on track.

AG_Caesar commented on 2016-06-05 21:51

I cant bulid, package seems broken
==> FEHLER:ttf-droid-sans-mono-dotted-powerline-git nicht im AUR gefunden.

==> ERROR:ttf-droid-sans-mono-dotted-powerline-git not found in AUR.

bowhuntr commented on 2016-02-07 12:00

No, I didn't customize the PKGBUILD. I will try what you suggested.


Thanks for the suggestion,it worked.

quixoten commented on 2016-02-06 17:10

@bowhuntr, that's interesting. Did you customize the PKGBUILD at one point and remove the dash between "droid" and "sans"? I would try running:

pacman -Rns otf-droidsansmono-powerline-git

Then try installing this package again.

bowhuntr commented on 2016-02-06 11:27

When I updated this package I got this error message at the end of the update, even though it seems the update completed just fine.

error: file owned by 'otf-droid-sans-mono-powerline-git' and 'otf-droidsansmono-powerline-git': 'usr/share/fonts/OTF/Droid Sans Mono for Powerline.otf'

quixoten commented on 2015-08-15 21:20

theNerd247, I recently built a new system on the latest archlinux and installed this package through yaourt. It installed without any errors. After digging around a bit, I was able to verify that the use of 'SKIP' is still the recommendation for VCS based sources (see last bullet point at https://wiki.archlinux.org/index.php/VCS_package_guidelines#Guidelines). I'm not sure what next steps I should take to try to reproduce your error. I will leave the package unchanged for now and hope that yours was an edge case that other users won't run into.

theNerd247 commented on 2015-07-15 14:50

md5sums=('SKIP') seems to cause the integrity checks to fail. I replaced with md5sums=() and it worked. I'm not sure if this is because the version of makepkg I'm using (though I just pacman -Syu yesterday).

quixoten commented on 2015-06-28 02:33

@toiffel, thanks for the tip.

https://aur4.archlinux.org/packages/ttf-droid-sans-mono-dotted-powerline-git/
https://aur4.archlinux.org/packages/ttf-droid-sans-mono-slashed-powerline-git/

I will backport these to aur.archlinux.org as well.

kodemeister commented on 2015-06-27 10:05

@quixoten, both Slashed and Dotted variations of Droid Sans Mono were recently pushed to powerline fonts repository. You might want to add them to this package or create separate packages for completeness.