Package Details: osu 20180917-1

Git Clone URL: https://aur.archlinux.org/osu.git (read-only)
Package Base: osu
Description: Freeware rhythm video game
Upstream URL: http://osu.ppy.sh
Licenses: custom
Submitter: ValdikSS
Maintainer: emersion
Last Packager: emersion
Votes: 44
Popularity: 0.004947
First Submitted: 2012-11-07 13:27
Last Updated: 2018-09-17 11:53

Latest Comments

1 2 3 4 5 6 ... Next › Last »

huupoke12 commented on 2019-04-19 13:28

I don't know if anyone having the same problem but osu! runs without rendering (there are still sounds, and I can still go into the game and quit using keyboard keys and mouse but can't see anything). When I quit, there is an error output:

X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  12 (X_ConfigureWindow)
  Resource id in failed request:  0x8e0006a
  Serial number of failed request:  255
  Current serial number in output stream:  255

Try installing lib32-libxcomposite to see if the problem is solved. If not, you can downgrade wine to 4.5.

aecsocket commented on 2019-04-12 08:32

Audio was not working for me. Fixed by installing lib32-alsa-* and lib32-libpulse from multilib.

alteax commented on 2019-02-05 16:30

"double free or corruption (!prev)" when trying to launch the game, anyone got the same issue?

huupoke12 commented on 2019-01-26 09:41

@siryx Try to open it multiple time. It fails to open when the terminal closed. I always have to open it like 2, 3 times before it can actually run (Just on the first launch after your PC booted).

siryx commented on 2019-01-11 23:10

Doesnt open at all for me as well. No output on the terminal at all. No DE, just i3 and composer. Installation seemed to work, was asked to install .net 4 twice though. Maybe two versions.

emersion commented on 2018-11-19 16:35

Not working for me. It just doesn't open.

Can you try to run it from a terminal and see what it outputs?

qwedas commented on 2018-09-21 23:55

I keep getting "ATTENTION: default value of option vblank_mode overridden by environment." when I try to run osu and I just get a blank screen. Anyone know how to fix this?

emersion commented on 2018-09-17 11:54

@LavaPower: should be fixed now

LavaPower commented on 2018-09-16 18:25

==> Validation des fichiers source avec md5sums… osu!install.exe ... Ignoré directsound-latency.reg ... Réussite osu.desktop ... Réussite osulauncher ... ÉCHEC osu.png ... Réussite

openglfreak commented on 2018-08-09 13:32

I made a patch that corrects and enhances some things:
https://pastebin.com/qspnAkWC
Apply using
patch osulauncher < patch_for_osu_aur_package.sh