Package Details: osticket 1.14.2-1

Git Clone URL: https://aur.archlinux.org/osticket.git (read-only, click to copy)
Package Base: osticket
Description: A widely-used open source support ticket system.
Upstream URL: http://www.osticket.com/
Licenses: GPL
Submitter: None
Maintainer: pizzaman
Last Packager: pizzaman
Votes: 5
Popularity: 0.000050
First Submitted: 2011-06-18 17:36
Last Updated: 2020-04-29 01:20

Latest Comments

« First ‹ Previous 1 2 3

sigmundv commented on 2015-04-23 20:55

@ArthurBorsboom: Thanks for the feedback! I should have tested this before I uploaded the package, but now I have fixed it and it should work!

ArthurBorsboom commented on 2015-04-21 18:48

==> Starting package()...
Extracting files
unzip: cannot find or open 1.9.7.tar.gz, 1.9.7.tar.gz.zip or 1.9.7.tar.gz.ZIP.
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build osticket.

sigmundv commented on 2015-04-20 22:50

PKGBUILD fixed and updated to v1.9.7.

ArthurBorsboom commented on 2014-10-13 10:27

There is an error in the PKGBUILD

The tar command needs to be replaced with an unzip statement

unzip -d DIRECTORY myzipfile.zip

Vryali commented on 2012-04-06 00:42

Thanks for having this in the AUR, I appreciate it!

Tiny problems with your PKGBUILD: you needed to {} your variables in two places so that it used them properly:

source=("http://osticket.com/dl/${pkgname}_${pkgver}.tar.gz")

tar -C ${pkgdir}/srv/http/osticket -xzf ${pkgname}_${pkgver}.tar.gz

... and then tar didn't like the use of -C without a -xzf, so adding the - there removed the tar error for me.

Before it was trying to use variable pkgname_ - which doesn't exist, this fixes that.

Thanks again =]