Package Details: osp-tracker 5.1.5-2

Git Clone URL: https://aur.archlinux.org/osp-tracker.git (read-only, click to copy)
Package Base: osp-tracker
Description: Tracker video analysis and modeling tool
Upstream URL: http://physlets.org/tracker/
Licenses: GPL3
Submitter: zookah
Maintainer: effeffe
Last Packager: effeffe
Votes: 5
Popularity: 0.082562
First Submitted: 2018-05-26 21:22
Last Updated: 2020-06-03 10:27

Dependencies (5)

Required by (0)

Sources (3)

Latest Comments

effeffe commented on 2020-06-03 10:29

Thanks for notification. The package has now been updated.

FYI if anyone wants to be added as a co-maintainer, just contact me

effeffe commented on 2020-04-29 20:22

Thank you bartus, I have just pushed your patch. Do I need to set you as a co-maintainer?

bartus commented on 2020-04-29 19:01

I've made a patch to fix prev issue

git am < <(curl -s http://ix.io/2k4)

bartus commented on 2020-04-18 11:56

Have a problem building version 5.1.4 in chroot.

==> Entering fakeroot environment...
==> Starting package()...
/build/osp-tracker/pkg/osp-tracker
  -> Starting Tracker installer
There has been an error.
Error reading file /build/.config/user-dirs.dirs
  -> Creating desktop file and symlinks
install: cannot stat '/build/osp-tracker/pkg/osp-tracker/opt/tracker/tracker_icon48.png': No such file or directory
==> ERROR: A failure occurred in package().

Looks like installer make use of xdg user-dirs - perhaps we could make it independent of user stuff ?

effeffe commented on 2020-02-08 21:42

The package has now been updated

drei commented on 2019-10-22 22:48

Please update the PKGBUILD and .SRCINFO files to accommodate for the new 5.1.2

The current source URL has an additional "/" included which causes the makepkg command to fail.

In .SRCINFO

source = http://physlets.org/tracker//installers/Tracker-5.0.5-linux-64bit-installer.run

It should be

source = http://physlets.org/tracker/installers/Tracker-5.1.2-linux-64bit-installer.run

In PKGBUILD

url='http://physlets.org/tracker/'

It should be

url='http://physlets.org/tracker'


Version should also be updated to match the new release 5.1.2

The installer needs the user-dirs.dirs files in the .config directory, so the xdg-user-dirs package should be added as a dependency.