Package Details: oscam-svn 11578-1

Git Clone URL: https://aur.archlinux.org/oscam-svn.git (read-only, click to copy)
Package Base: oscam-svn
Description: The Open Source Conditional Access Module daemon
Upstream URL: http://www.streamboard.tv/oscam
Licenses: GPL3
Conflicts: oscam
Provides: oscam
Submitter: None
Maintainer: LukyLX
Last Packager: LukyLX
Votes: 12
Popularity: 0.000152
First Submitted: 2011-01-22 15:09
Last Updated: 2020-04-08 06:48

Required by (2)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

jhernberg commented on 2013-05-08 07:55

I've added After=tmp.mount to the service file, should work if the mounting of /tmp was what messed up the socket. Probably a better place for it would bin in /run, but I'm not going to make such a change since it will break all packages using oscam...

I've asked the devs, and they say that the only valid archs are i686, and x86_64, so I'm not going to add another one to the build. Easy enough for the user to do himself if he needs to.

Have added suversion as a makedepend, but don't think make and gcc need to be explicitly specified. In any case it builds fine in a chroot, so I think the build is ok.

elpadre commented on 2013-04-28 19:43

can you add armv6h to arch?
arch=('armv6h')
Also subversion, make and gcc are also dependencies

elpadre commented on 2013-04-28 18:02

can you add armv6h to arch?
arch=('armv6h')
Also subversion, make and gcc are also dependencies

Anonymous comment on 2013-04-08 16:44

Sometimes I find oscam is unable to write the /tmp/camd.socket when I start my PC.

I'm not sure but maybe adding something like 'After=tmp.mount' to the service file might help.

Anonymous comment on 2012-11-14 20:45

I solved my linking problems (before the change from cmake to make) by adding -DSTATIC_LIBUSB=0 in PKGBUILD. Othervise the linker complained about missing static libraries.

cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DWEBIF=1 \
-DHAVE_DVBAPI=1 \
-DSTATIC_LIBUSB=0 \
-WITH_SSL=1 \
"$srcdir/$_svnmod-build"

jhernberg commented on 2012-11-10 17:20

I have changed the script over to use make instead of cmake, and it appears to build fine and works for me. I am not quite sure about all the options, but have tried to include everything that might be needed on a PC. Please let me know if something is missing or broken! Have fun :)

jhernberg commented on 2012-11-06 15:37

This build fails for me with /usr/bin/ld: cannot find -lusb-1.0, be it chroot with devtools or not. configure.sh appears to find it. I have to build with a -DHAVE_LIBUSB=0 argument to cmake to finish making the package. Any ideas what i'm missing? My system has libusbx installed, and I tried to add it to the depends array, but still it won't build :(

Anonymous comment on 2012-09-21 23:08

Unit file oscam.service for systemd

[Unit]
Description=An Open Source Conditional Access Module software

[Service]
Type=forking
EnvironmentFile=/etc/conf.d/oscam
ExecStart=/usr/bin/oscam $OSCAM_ARGS

[Install]
WantedBy=multi-user.target

Anonymous comment on 2012-08-27 21:44

Please change source link to: http://streamboard.de.vu/svn/oscam/trunk oscam-trunk

Anonymous comment on 2012-06-26 08:50

stop() method in rc.d script doesn't work...fix it adding -9 option:

killall -9 oscam