Package Details: optix 7.4.0-1

Git Clone URL: https://aur.archlinux.org/optix.git (read-only, click to copy)
Package Base: optix
Description: An application framework for achieving optimal ray tracing performance on the GPU.
Upstream URL: https://developer.nvidia.com/optix
Licenses: custom:NVIDIA
Submitter: yvbbrjdr
Maintainer: yvbbrjdr (bartus)
Last Packager: bartus
Votes: 7
Popularity: 0.44
First Submitted: 2019-05-14 06:35
Last Updated: 2021-12-02 14:16

Dependencies (1)

Required by (5)

Sources (2)

Pinned Comments

bartus commented on 2021-01-21 21:25

If you need previous version of Optix please clone specific version branch for my github mirror:

e.g: Optix:7.1

git clone --branch 71 https://github.com/bartoszek/AUR-optix

and build with makepkg or your aur helper of choice (ღ˘⌣˘ღ)

makepkg -sri

Latest Comments

1 2 Next › Last »

xrayfur commented on 2021-12-02 12:10

New release 7.4.0

% sha256sum NVIDIA-OptiX-SDK-7.4.0-linux64-x86_64.sh 
d5f17a50054d24db06e0fd789f79ba8a510efa780bfd940f0da1da9aff499ca0  NVIDIA-OptiX-SDK-7.4.0-linux64-x86_64.sh

bartus commented on 2021-01-21 21:25

If you need previous version of Optix please clone specific version branch for my github mirror:

e.g: Optix:7.1

git clone --branch 71 https://github.com/bartoszek/AUR-optix

and build with makepkg or your aur helper of choice (ღ˘⌣˘ღ)

makepkg -sri

yvbbrjdr commented on 2020-07-13 16:54

@bwrsandman I'll do it recently.

bwrsandman commented on 2020-06-17 09:54

Having issues including optix with cmake and find_package(OptiX MODULE REQUIRED VERSION 7.0)

Adding -DCMAKE_MODULE_PATH=/opt/optix/SDK/CMake to the cmake command but the path in /opt/optix/SDK/CMake/FindOptiX.cmake is wrong and should be

set(OptiX_INSTALL_DIR "${CMAKE_CURRENT_LIST_DIR}/../../" CACHE PATH "Path to OptiX installed location.")

Perhaps this could be patched in the package?

yvbbrjdr commented on 2019-12-14 19:57

@bartus: The package (optix-6.5) was really really big. But it doesn't seem to be a problem in 7.0 now. I'll remove the no compression option.

bartus commented on 2019-10-19 14:55

@yvbbrjdr: What is the rationale for enforcing no compression on the packge...

yvbbrjdr commented on 2019-10-09 17:36

I used hib because I saw somewhere else also uses hib for legal reasons.

kureta commented on 2019-10-02 06:33

@yvbbrjdr Is there any reason you've used hib protocol. I had the same problem. I guess I didn't have humble bundle dl agent so I didn't see the warning. Would you like me to change the way users are notified, especially when using yay or things like that?

yvbbrjdr commented on 2019-10-02 06:29

You need to manually download NVIDIA-OptiX-SDK-7.0.0-linux64.sh from NVIDIA's site. It's illegal to distribute the file here.

Lordchelo commented on 2019-10-01 12:02

==> Validando los archivos source con sha512sums... NVIDIA-OptiX-SDK-7.0.0-linux64.sh ... NO ENCONTRADO ==> ERROR: ¡Uno o más archivos no superaron el control de validación! Error downloading sources: optix