Package Details: openvpn-nordvpn 0.1.39-0

Git Clone URL: https://aur.archlinux.org/openvpn-nordvpn.git (read-only, click to copy)
Package Base: openvpn-nordvpn
Description: OpenVPN helper script for nordvpn.com
Upstream URL: https://github.com/nstinus/nordvpn
Keywords: nordvpn openvpn
Licenses: MIT
Provides: nordvpn
Submitter: nstinus
Maintainer: nstinus
Last Packager: nstinus
Votes: 22
Popularity: 0.002343
First Submitted: 2017-02-01 16:40
Last Updated: 2019-05-12 13:20

Dependencies (17)

Required by (0)

Sources (1)

Pinned Comments

nstinus commented on 2017-03-06 14:31

Thank you for your support!

This package is comprised of a convenience utility to start, stop, list the servers. It also downloads and installs config files from nordvpn. See its help for available commands and usage (sudo nordvpn -h).

For any issue or feature request, please do so on https://github.com/nstinus/nordvpn/issues.

Latest Comments

1 2 3 4 Next › Last »

archieslove commented on 2020-01-20 23:30

Thank you for the work. It works great. is there any guide to auto connect after sleep/resume ?

PedroHLC commented on 2019-03-22 16:36

Please, add git in makedepends, it's required when building from a clean chroot!

iMike commented on 2018-10-21 21:11

Tried installing for the first time, but ran into a problem caused by a commit. See below. PS I got it to work. Really not sure how. I leave this comment since it appear something went wrong that might be worth looking at.

 Building openvpn-nordvpn...
 Cloning into 'openvpn-nordvpn'...
 [...]
 == Extracting sources...
 - Creating working copy of nordvpn git repo...
 Cloning into 'nordvpn'...
 done.
 fatal: 'v0.1-32-g595937f' is not a commit and a branch 'makepkg' cannot be
created from it == ERROR: Failure while creating working copy of nordvpn git repo Aborting...

verasmaia commented on 2018-04-19 17:22

Thank you for the script.

It failed updating servers today, most probably due to the changes on NordVPN's side. You might want to change line 87 of your script:

Please let me know if you have a better suggestion.

Denzo commented on 2017-11-30 18:28

The rank command uses fping, which is not listed as a dependency. Might be useful to add it so the script doesn't crash when ranking :)

redman commented on 2017-10-23 15:14

And you nstinus, thanks for your painless fix :)
Great!

nstinus commented on 2017-10-23 13:55

@redman I pushed a fix. My apologies for the bad commit :/

redman commented on 2017-10-23 05:49

Since a week I use this tool, so I now first have to thank you!

I now tried to update in Pamac but helas ...
Thanks in advance for your ongoing efforts!

#
Synchronizing package databases...
Starting full system upgrade...

Preparing...

Building openvpn-nordvpn...
Cloning into 'openvpn-nordvpn'...
remote: Counting objects: 276, done.
remote: Compressing objects: 100% (231/231), done.
remote: Total 276 (delta 134), reused 104 (delta 45)
Receiving objects: 100% (276/276), 38.90 KiB | 2.43 MiB/s, done.
Resolving deltas: 100% (134/134), done.
==> Making package: openvpn-nordvpn 0.1.32-1 (Mon 23 Oct 07:37:18 CEST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning nordvpn git repo...
Cloning into bare repository '/tmp/pamac-build-afw/openvpn-nordvpn/nordvpn'...
remote: Counting objects: 358, done.
remote: Compressing objects: 100% (52/52), done.
remote: Total 358 (delta 62), reused 118 (delta 59), pack-reused 235
Receiving objects: 100% (358/358), 62.30 KiB | 701.00 KiB/s, done.
Resolving deltas: 100% (177/177), done.
==> Validating source files with sha1sums...
nordvpn ... Skipped
==> Extracting sources...
-> Creating working copy of nordvpn git repo...
Cloning into 'nordvpn'...
done.
fatal: 'v0.1-32-g595937f' is not a commit and a branch 'makepkg' cannot be created from it
==> ERROR: Failure while creating working copy of nordvpn git repo
Aborting...

Drahull commented on 2017-06-30 18:37

Thanks for this tool.
There is a little error, not a big issue but a little bit annoying to progress display ^^ : line 19 printf : *float number* : invalid (expect an int ?)

It happens when running the update.

nstinus commented on 2017-05-24 22:43

@DryEagle; As mentionned before, this tools *is* some shell script...
Anyway, I just implemented solution 2 mentioned before meaning that a new command has been added: nordvpn update. It will download, patch and install a fresh set of files from nordvpn.