Package Details: openvas-scanner 21.4.2-1

Git Clone URL: https://aur.archlinux.org/openvas-scanner.git (read-only, click to copy)
Package Base: openvas-scanner
Description: Vulnerability scanning Daemon
Upstream URL: https://github.com/greenbone/openvas-scanner
Licenses: GPL
Groups: greenbone-vulnerability-manager
Submitter: mfulz
Maintainer: mfulz
Last Packager: mfulz
Votes: 0
Popularity: 0.000000
First Submitted: 2021-02-16 22:17
Last Updated: 2021-08-25 10:13

Latest Comments

1 2 Next › Last »

fortw commented on 2021-04-28 07:02

yep, pretty sure it was me who messed up regarding the permissiongs ;-)

mfulz commented on 2021-04-23 22:22

Thanks for the info I've added rsync as dependency. For the permission I think you messed something up during analysis as this is already set by gvm-libs-20

fortw commented on 2021-04-23 10:00

I added a set -x to the greenbone-nvt-sync script and could identify two issues:

  1. I think the combination of sudo -iu/su - with /dev/stderr in this script don't work well (https://unix.stackexchange.com/questions/38538/bash-dev-stderr-permission-denied) which is the cause for "Permission denied". This hides the real issue, namely

  2. there is an undeclared dependency on rsync. Installing it manually solves this issue

However, then I have to do

sudo chown -R gvm:gvm /var/lib/openvas

otherwise rsync will fail to create stuff in the /var/lib/openvas/plugins folder. not sure though, whether I did something wrong somewhere to end up with this problem.

fortw commented on 2021-04-22 22:56

Same problem as r0b0t (although, for reasons, I went with sudo -iu gvm before). I installed the packages as stated in the wiki. First ospd Afterwards openvas-scanner ospd-openvas gsa gvmd

(There was a conflict: gvm-libs-20 and gvm-libs)

mfulz commented on 2021-04-19 10:07

Can you check (if not already done) the wiki, which I've updated to work with these set of packages: https://wiki.archlinux.org/index.php/OpenVAS

If you still encountering any issues afterwards, feel free to get back again.

r0b0t commented on 2021-04-19 00:05

Did anyone else have this error? [root@arch roh]# su - gvm [gvm@arch ~]$ greenbone-nvt-sync && sudo openvas --update-vt-info /usr/bin/greenbone-nvt-sync: line 135: /dev/stderr: Permission denied

DavTheRaveUK commented on 2021-03-14 00:24

Hi, my line 23 has no dots but line 24 does: 24. -DOPENVAS_FEED_LOCK_PATH=/run/gvm/feed-update.lock --debug-output .

Is this how you want it? Thanks. Dave.

mfulz commented on 2021-03-09 10:47

Can you please add --debug-output to the PKGBUILD file at line 23 before the dot and resend me the output afterwards? I've tried with exact the same versions and optional packages like in your output but still it compiles fine for me.

DavTheRaveUK commented on 2021-03-08 16:41

Sure :)

mfulz commented on 2021-03-08 15:39

Till now I wasn't able to figure out whats not working on your side, but I'm on it please be a little patient ^^