Package Details: opentx-companion-bin 2.3.9-1

Git Clone URL: https://aur.archlinux.org/opentx-companion-bin.git (read-only, click to copy)
Package Base: opentx-companion-bin
Description: Models and settings editor for the OpenTX open source firmware.
Upstream URL: http://www.open-tx.org/
Licenses: GPL
Conflicts: companion, companion9x-svn
Provides: companion
Submitter: alexmeyer
Maintainer: alexmeyer (bjin)
Last Packager: bjin
Votes: 3
Popularity: 0.93
First Submitted: 2019-06-13 13:46
Last Updated: 2020-06-15 21:09

Latest Comments

smendez commented on 2020-04-23 18:05

I went ahead and looked further into this and the following pseudo-diff shows my local edit that I tested which works.


PKGBUILD:
..
..
.
cd "${pkgdir}"

mv usr/local/bin usr/bin

- mv usr/local/lib usr/lib + cp -r usr/local/lib usr/lib # Use copy because we still want files in /usr/lobal/lib. They are used by simulator

mv lib/* usr/lib rm -r lib

Feel free to audit and incorporate.

Thanks!

smendez commented on 2020-04-23 13:24

FYI, I just installed this (currently version 2.3.7-1) and I am getting the "Warning Simulator for this Firmware is not yet available" message.

When running from the command line, I see this:

[D] SimulatorLoader::registerSimulators():55 - [simulator.interface.loader] Searching for simulators in "." matching pattern ("-simulator.so") [D] SimulatorLoader::registerSimulators():83 - [simulator.interface.loader] Found libraries: ("none") [D] SimulatorLoader::registerSimulators():55 - [simulator.interface.loader] Searching for simulators in "/usr/local/lib/companion23" matching pattern ("-simulator.so") [D] SimulatorLoader::registerSimulators():83 - [simulator.interface.loader] Found libraries: ("none")

The workaround below suggested by stackoverflow128 worked for me. Another workaround is to launch companion23 from the /usr/lib/companion23 directory.

Can you please look into this?

alexmeyer commented on 2019-06-17 19:41

@stackoverflow128 good catch, thanks. I pushed a fix for that, should be good now!

stackoverflow128 commented on 2019-06-17 18:59

To fix the error "Warning Simulator for this Firmware is not yet available ." run the following command.

cp /usr/lib/companion22/libopentx-* /usr/local/lib/companion22/