Package Details: openshot-git 2.4.4.r601.g1a7ebc1f-1

Git Clone URL: https://aur.archlinux.org/openshot-git.git (read-only, click to copy)
Package Base: openshot-git
Description: An open-source, non-linear video editor for Linux based on MLT framework (git version)
Upstream URL: https://www.openshot.org/
Licenses: GPL3
Conflicts: openshot
Provides: openshot
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 22
Popularity: 0.000002
First Submitted: 2017-07-24 01:20
Last Updated: 2020-01-03 21:54

Latest Comments

« First ‹ Previous 1 2

Jhackler commented on 2015-06-24 17:05

Well I haven't had a chance to mess with it, if you manage to try it and get a working package build just let me know.

cgirard commented on 2015-06-24 10:30

No, not yet.

Jhackler commented on 2015-06-23 16:13

hey have you attempted to build what seems to be the 2.x dev branch which can be found here https://github.com/OpenShot ?

cgirard commented on 2013-09-19 22:21

Adopted and updated. Based on [community] PKGBUILD

Anonymous comment on 2012-01-30 10:45

Maybe you should explicitly declare "conflicts=(openshot)" since you can't install both.

Anonymous comment on 2011-03-20 00:34

Not work, write this:

--------------------------------
OpenShot (version 1.3.1~alpha1)
--------------------------------
Process no longer exists: 2989. Creating new pid lock file.
*** ERROR: MLT Python bindings failed to import ***
*** ERROR: MLT Python bindings failed to import ***
*** ERROR: MLT Python bindings failed to import ***
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 530, in __bootstrap_inner
self.run()
File "/usr/lib/python2.7/site-packages/openshot/classes/thumbnail.py", line 170, in run
mlt.Factory().init()
NameError: global name 'mlt' is not defined

*** ERROR: MLT Python bindings failed to import ***

------------------------- ERROR 2 ------------------------------
Failed to import 'from openshot.openshot import main'
Error Message: libpython3.2mu.so.1.0: cannot open shared object file: No such file or directory
----------------------------------------------------------------

library libpython3.2mu.so.1.0 provided by python package(python 2.7)

When i installed this package, openshot work good. Add please python to dependencies

BoySka commented on 2010-09-17 19:20

I'm not sure, but I think it depends on blender

firewalker commented on 2010-09-14 13:13

Ok, I found the error. There a folder named [b]icons[/b] in [b]transitions[/b]. setup.py was trying to copy this folder as a regular file. The [b]transitions/icons[/b] folder must be declared separately. The following patch fixes the issue.

http://aur.pastebin.com/eLKdJkGi

patch -p0 < setup.diff[

firewalker commented on 2010-09-14 13:10

]Ok, I found the error. There a folder named icons in transitions. setup.py was trying to copy this folder as a regular file. The transitions/icons folder must be declered seperately. The following patch fixes the issue.

setup.diff

=== modified file 'setup.py'
--- setup.py 2010-05-31 21:31:32 +0000
+++ setup.py 2010-09-14 12:57:43 +0000
@@ -58,7 +58,7 @@
scripts = ['bin/openshot','bin/openshot-render'],
packages = ['openshot', 'openshot.classes', 'openshot.language', 'openshot.windows'],
package_data = {
- 'openshot' : ['export_presets/*', 'images/*', 'locale/OpenShot/*', 'locale/README', 'profiles/*', 'themes/*/*.png', 'themes/*/icons/*.png', 'titles/*/*.svg', 'transitions/*', 'effects/icons/*.png', 'effects/*.xml'] + locale_files,
+ 'openshot' : ['export_presets/*', 'images/*', 'locale/OpenShot/*', 'locale/README', 'profiles/*', 'themes/*/*.png', 'themes/*/icons/*.png', 'titles/*/*.svg', 'transitions/icons/*', 'transitions/*.png', 'effects/icons/*.png', 'effects/*.xml'] + locale_files,
'openshot.windows' : ['ui/*.ui', 'ui/icons/*'],
},
data_files = os_files,


Apply with

patch -p0 < setup.diff

firewalker commented on 2010-07-25 18:05

I have the following error:

copying openshot/transitions/hatched_2.png -> build/lib/openshot/transitions
copying openshot/transitions/hatched_3.png -> build/lib/openshot/transitions
error: can't copy 'openshot/transitions/icons': doesn't exist or not a regular file