Package Details: openrct2-git r19968.0ae86d055-1

Git Clone URL: https://aur.archlinux.org/openrct2-git.git (read-only, click to copy)
Package Base: openrct2-git
Description: Open source re-implementation of Roller Coaster Tycoon 2 (requires full copy of the game)
Upstream URL: https://openrct2.io
Licenses: GPL3
Conflicts: openrct2
Provides: openrct2
Submitter: grahamedgecombe
Maintainer: grahamedgecombe
Last Packager: grahamedgecombe
Votes: 25
Popularity: 0.000000
First Submitted: 2014-05-27 09:56
Last Updated: 2020-09-21 18:06

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 Next › Last »

grahamedgecombe commented on 2016-06-18 10:12

r.e. lib32-libpulse comments, I've previous written about this in a previous comment:

"@phantom94: OpenRCT2 plays sound using SDL2, and thus depends on lib32-sdl2. lib32-sdl2 does not directly depend on the 32-bit ALSA/PulseAudio libraries - they are optional dependencies, and you need to pick and manually install the one appropriate for your system."

I don't want to do a hard dep in case people want to avoid PA ending up on their system.

However, I've added the optdepends to this package too to make it more obvious for people who don't read the optdepends of the dependencies.

As you're using OpenGL through SDL_opengl.h I think I'll just rely on the transitive dep.

janisozaur commented on 2016-06-13 21:36

Can you add lib32-libpulse as a dependency as well or perhaps suggest it to the user? See https://github.com/OpenRCT2/OpenRCT2/issues/3872#issuecomment-225645297

We have also merged new OpenGL code, but sdl already depends on it… See https://github.com/OpenRCT2/OpenRCT2/pull/3862

Anonymous comment on 2016-06-13 21:35

based on https://github.com/OpenRCT2/OpenRCT2/issues/3872, maybe it's an idea to add lib32-libpulse to this package as dependency, as this enables the audio.

grahamedgecombe commented on 2016-05-28 08:14

thanks, added

janisozaur commented on 2016-05-27 18:32

We're about to merge https://github.com/OpenRCT2/OpenRCT2/pull/3699, it will explicitly require openssl. This is already a dependency of curl (through libssh2), but would be good to include it here as well.

janisozaur commented on 2016-05-09 07:02

We've merged the .desktop file now: https://github.com/OpenRCT2/OpenRCT2/pull/3507

We may install it with our cmake scripts in the future: https://github.com/OpenRCT2/OpenRCT2/issues/3531

grahamedgecombe commented on 2016-03-24 12:49

@janisozaur: I've changed it to match the description on the upstream GitHub repo (which is where I think I got the original pkgdesc from in the first place, but it looks like the description was changed at some point).

janisozaur commented on 2016-03-23 21:47

@grahamedgecombe perhaps you could change the description of package slightly.

I feel "Open source engine for RollerCoaster Tycoon 2" would be a better fit. I've also seen other such packages mention a blurb like "requires full copy of the game" in the oneliner, what's your view on that?

phantom94 commented on 2016-03-23 17:31

@grahamedgecombe Thanks for the info! I had to install lib32-libpulse.

grahamedgecombe commented on 2016-03-01 19:46

@DrDoctor: This is because lib32-curl hasn't been rebuilt against openssl 1.0.2f yet - nothing to do with this package. You'll either have to wait for the maintainer to rebuild it, or rebuild it yourself with ABS.

@phantom94: OpenRCT2 plays sound using SDL2, and thus depends on lib32-sdl2. lib32-sdl2 does not directly depend on the 32-bit ALSA/PulseAudio libraries - they are optional dependencies, and you need to pick and manually install the one appropriate for your system.

@papperwing: Are you able to give more details? Btw, there's now an "openrct2 set-rct2" command so you can simply run "openrct2 set-rct2 /path/to/rct2" to avoid having to edit the config file by hand.