Package Details: openrc-git 0.42.42.g08d518b7-1

Git Clone URL: https://aur.archlinux.org/openrc-git.git (read-only, click to copy)
Package Base: openrc-git
Description: Dependency based init system that works with sysvinit.
Upstream URL: http://www.gentoo.org/proj/en/base/openrc/
Keywords: alpine funtoo gentoo init rc runit systemd sysvinit
Licenses: BSD
Conflicts: openrc
Provides: init-rc, libeinfo.so, librc.so, openrc, svc-manager
Submitter: ilikenwf
Maintainer: eatmyvenom
Last Packager: eatmyvenom
Votes: 19
Popularity: 0.022422
First Submitted: 2011-09-11 05:53
Last Updated: 2021-03-17 06:59

Dependencies (5)

Required by (42)

Sources (2)

Latest Comments

1 2 Next › Last »

Alad commented on 2015-09-29 16:18

Arguably this should depend on a specific version of libncurses, e.g depends=('libncurses.so.6'). Same for the non-git package.

Sanpi commented on 2015-09-18 14:32

/!\ ncurses package updated to version 6. This makes it impossible to boot.

apg commented on 2013-06-02 15:48

Updated. If you're using openrc-arch-services-git make sure you upgrade it as well.

Lone_Wolf commented on 2013-06-01 09:05

https://mailman.archlinux.org/pipermail/arch-dev-public/2013-May/025003.html

Both this package and the non-git version will give a conflict with the soon to come move from /bin, /sbin , /usr/sbin to /usr/bin .

Anonymous comment on 2013-01-21 05:20

I love openrc better than systemd and no brainfuck.

Anonymous comment on 2012-11-15 22:19

Thanks for this, it really is appreciated, works really well.

apg commented on 2012-11-10 14:09

I've been using OpenRC for a couple months now, so I'm not sure I agree with "not ready for everyday use." Although, obviously, if you use a DE that requires systemd it won't work for you, but that's not something that's going to be fixed in this package.

net-tools was missing as a dependency, your network issue should be fixed now.

artoo commented on 2012-11-10 10:05

Same comment as on openrc.sysvinit:
https://bbs.archlinux.org/viewtopic.php?id=152606

artoo commented on 2012-11-10 10:03

I made a forum post concerning OpenRC here:
https://bbs.archlinux.org/viewtopic.php?id=152606

I managed to to fix a couple of bugs and OpenRC now runs fine.
But, OpneRC pkgbuilds are not ready for everyday use at the moment, they lack network support entirely.
I would be willing to help.

apg commented on 2012-11-09 22:23

I'll support it for as long as I can spare the time necessary.