Package Details: openra-d2-git 189.git.3c1489a-1

Git Clone URL: https://aur.archlinux.org/openra-d2-git.git (read-only, click to copy)
Package Base: openra-d2-git
Description: A Dune II-inspired mod of OpenRA
Upstream URL: https://github.com/OpenRA/d2
Licenses: GPL3
Provides: openra-d2
Submitter: fusion809
Maintainer: fusion809
Last Packager: fusion809
Votes: 1
Popularity: 0.001766
First Submitted: 2019-03-23 11:23
Last Updated: 2020-06-15 14:31

Latest Comments

« First ‹ Previous 1 2

fusion809 commented on 2019-09-02 13:42

If you still get this error, I suggest uninstalling what old version of Mono you're using and use the official 'mono' package instead. If you are, then update your system, as if your mono is <5.4, you mustn't have updated your Arch install for months.

fusion809 commented on 2019-09-02 13:34

@Mr.Smith1974, has that latest commit fixed your problem? As mono>=5.4 should now be hardcoded as a requirement, which your error indicates is what was the problem, your system was trying to build it, despite having a version of Mono lower than that.

fusion809 commented on 2019-09-02 13:32

Mr.Smith1974: it isn't out of date, build errors belong in comments, not in package flags. I'm working on your problem, be patient.

Mr.Smith1974 commented on 2019-09-02 13:29

<!--

==> Making package: openra-d2-git 166.git.0a74333-1 (Пн 02 сен 2019 16:19:35)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
Version changed to 166.git.0a74333.
OpenRA requires the 'msbuild -verbosity:m -nologo' tool provided by Mono >= 5.4.
make: *** [Makefile:116: core] Error 1
==> ERROR: A failure occurred in build().
Aborting...

-->