Package Details: openoffice 4.1.6-1

Git Clone URL: https://aur.archlinux.org/openoffice.git (read-only)
Package Base: openoffice
Description: Apache OpenOffice
Upstream URL: http://www.openoffice.org
Licenses: Apache
Conflicts: openoffice-base-bin-unstable
Replaces: openoffice-base-bin
Submitter: SibrenVasse
Maintainer: oberon2007
Last Packager: oberon2007
Votes: 34
Popularity: 0.197572
First Submitted: 2015-08-12 10:52
Last Updated: 2018-11-21 10:20

Dependencies (17)

Sources (2)

Latest Comments

1 2 3 Next › Last »

danisantos commented on 2019-05-23 12:38

I have changed my openjdk java version to 8 (jre) to support openoffice and now I get this error:

Application Error

Fatal exception: Signal 6
Stack:
/opt/openoffice4/program/libuno_sal.so.3(+0x37c3a)[0x7f1385c67c3a]
/opt/openoffice4/program/libuno_sal.so.3(+0x37d6c)[0x7f1385c67d6c]
/opt/openoffice4/program/libuno_sal.so.3(+0x37e09)[0x7f1385c67e09]
/usr/lib/libc.so.6(+0x378b0)[0x7f13853778b0]
/usr/lib/libc.so.6(gsignal+0x10f)[0x7f138537782f]
/usr/lib/libc.so.6(abort+0x125)[0x7f1385362672]
/opt/openoffice4/program/libvcl.so(+0x1557b5)[0x7f1381f5d7b5]
/opt/openoffice4/program/libsofficeapp.so(+0x2354b)[0x7f13859c354b]
/opt/openoffice4/program/libvcl.so(+0x17ff06)[0x7f1381f87f06]
/opt/openoffice4/program/libuno_sal.so.3(+0x36a02)[0x7f1385c66a02]
/opt/openoffice4/program/libuno_sal.so.3(+0x37dea)[0x7f1385c67dea]
/usr/lib/libc.so.6(+0x378b0)[0x7f13853778b0]
/usr/lib/libc.so.6(gsignal+0x10f)[0x7f138537782f]
/usr/lib/libc.so.6(abort+0x125)[0x7f1385362672]
/usr/lib/libfontconfig.so.1(+0x8026)[0x7f1378e78026]
/usr/lib/libfontconfig.so.1(+0x1d804)[0x7f1378e8d804]
/usr/lib/libfontconfig.so.1(+0x1db3e)[0x7f1378e8db3e]
/usr/lib/libfontconfig.so.1(+0x1dc89)[0x7f1378e8dc89]
/usr/lib/libfontconfig.so.1(FcFontMatch+0x71)[0x7f1378e8ea31]
/opt/openoffice4/program/libvcl.so(+0x13734d)[0x7f1381f3f34d]
/opt/openoffice4/program/libvcl.so(+0x1373de)[0x7f1381f3f3de]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager20countFontconfigFontsERSt8hash_mapIN3rtl7OStringEiNS2_11OStringHashESt8equal_toIS3_EE+0x35)[0x7f1381f40c13]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager10initializeEv+0x247)[0x7f1381f4c21b]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager3getEv+0x49)[0x7f1381f4d0df]
/opt/openoffice4/program/libvclplug_gen.so(_ZN14X11SalGraphics14GetDevFontListEP15ImplDevFontList+0x2c)[0x7f137a640136]
/opt/openoffice4/program/libvcl.so(+0x25a058)[0x7f1382062058]
/opt/openoffice4/program/libvcl.so(+0x260bb0)[0x7f1382068bb0]
/opt/openoffice4/program/libvcl.so(_ZNK12OutputDevice13GetTextHeightEv+0x12)[0x7f138206b272]
/opt/openoffice4/program/libvcl.so(+0x2637fa)[0x7f138206b7fa]
/opt/openoffice4/program/libvcl.so(_ZN12OutputDevice8DrawTextERK9RectangleRK6StringtPSt6vectorIS0_SaIS0_EEPS3_PN3vcl11ITextLayoutE+0x195)[0x7f138206f5f1]
/opt/openoffice4/program/../program/libspl.so(+0x11a1e)[0x7f13741f9a1e]
/opt/openoffice4/program/../program/libspl.so(+0x1129c)[0x7f13741f929c]
/opt/openoffice4/program/../program/libspl.so(+0x128dd)[0x7f13741fa8dd]
/opt/openoffice4/program/libsofficeapp.so(+0x3c19c)[0x7f13859dc19c]
/opt/openoffice4/program/../program/deployment.uno.so(+0x54948)[0x7f136eacc948]
/opt/openoffice4/program/libdeploymentmisc.so(_ZN7dp_misc16syncRepositoriesERKN3com3sun4star3uno9ReferenceINS2_3ucb19XCommandEnvironmentEEE+0x460)[0x7f138482b170]
/opt/openoffice4/program/libsofficeapp.so(+0x3c240)[0x7f13859dc240]
/opt/openoffice4/program/libsofficeapp.so(+0x2c857)[0x7f13859cc857]
/opt/openoffice4/program/libvcl.so(+0x1807eb)[0x7f1381f887eb]
/opt/openoffice4/program/libvcl.so(_Z6SVMainv+0x1e)[0x7f1381f888b6]
/opt/openoffice4/program/libsofficeapp.so(soffice_main+0x9c)[0x7f13859f4fac]
/opt/openoffice4/program/soffice.bin(main+0xb)[0x400f7b]
/usr/lib/libc.so.6(__libc_start_main+0xf3)[0x7f1385363ce3]
/opt/openoffice4/program/soffice.bin(__gxx_personality_v0+0xb9)[0x400eb9]
/opt/openoffice4/program/soffice: linha 121:  1495 Aborted                 (núcleo despejado) "$sd_prog/$sd_binary" "$@"

danisantos commented on 2019-05-20 21:17

@oberon2007 I'm on Manjaro Deepin. My archlinux-java get gives java-11-openjdk and running openoffice4 gives me this error

javaldx: Could not find a Java Runtime Environment!
Application Error

Fatal exception: Signal 6
Stack:
/opt/openoffice4/program/libuno_sal.so.3(+0x37c3a)[0x7fde6b45fc3a]
/opt/openoffice4/program/libuno_sal.so.3(+0x37d6c)[0x7fde6b45fd6c]
/opt/openoffice4/program/libuno_sal.so.3(+0x37e09)[0x7fde6b45fe09]
/usr/lib/libc.so.6(+0x378b0)[0x7fde6ab6f8b0]
/usr/lib/libc.so.6(gsignal+0x10f)[0x7fde6ab6f82f]
/usr/lib/libc.so.6(abort+0x125)[0x7fde6ab5a672]
/opt/openoffice4/program/libvcl.so(+0x1557b5)[0x7fde677557b5]
/opt/openoffice4/program/libsofficeapp.so(+0x2354b)[0x7fde6b1bb54b]
/opt/openoffice4/program/libvcl.so(+0x17ff06)[0x7fde6777ff06]
/opt/openoffice4/program/libuno_sal.so.3(+0x36a02)[0x7fde6b45ea02]
/opt/openoffice4/program/libuno_sal.so.3(+0x37dea)[0x7fde6b45fdea]
/usr/lib/libc.so.6(+0x378b0)[0x7fde6ab6f8b0]
/usr/lib/libc.so.6(gsignal+0x10f)[0x7fde6ab6f82f]
/usr/lib/libc.so.6(abort+0x125)[0x7fde6ab5a672]
/usr/lib/libfontconfig.so.1(+0x8026)[0x7fde5e670026]
/usr/lib/libfontconfig.so.1(+0x1d804)[0x7fde5e685804]
/usr/lib/libfontconfig.so.1(+0x1db3e)[0x7fde5e685b3e]
/usr/lib/libfontconfig.so.1(+0x1dc89)[0x7fde5e685c89]
/usr/lib/libfontconfig.so.1(FcFontMatch+0x71)[0x7fde5e686a31]
/opt/openoffice4/program/libvcl.so(+0x13734d)[0x7fde6773734d]
/opt/openoffice4/program/libvcl.so(+0x1373de)[0x7fde677373de]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager20countFontconfigFontsERSt8hash_mapIN3rtl7OStringEiNS2_11OStringHashESt8equal_toIS3_EE+0x35)[0x7fde67738c13]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager10initializeEv+0x247)[0x7fde6774421b]
/opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager3getEv+0x49)[0x7fde677450df]
/opt/openoffice4/program/libvclplug_gen.so(_ZN14X11SalGraphics14GetDevFontListEP15ImplDevFontList+0x2c)[0x7fde5fe38136]
/opt/openoffice4/program/libvcl.so(+0x25a058)[0x7fde6785a058]
/opt/openoffice4/program/libvcl.so(+0x260bb0)[0x7fde67860bb0]
/opt/openoffice4/program/libvcl.so(_ZNK12OutputDevice13GetTextHeightEv+0x12)[0x7fde67863272]
/opt/openoffice4/program/libvcl.so(+0x2637fa)[0x7fde678637fa]
/opt/openoffice4/program/libvcl.so(_ZN12OutputDevice8DrawTextERK9RectangleRK6StringtPSt6vectorIS0_SaIS0_EEPS3_PN3vcl11ITextLayoutE+0x195)[0x7fde678675f1]
/opt/openoffice4/program/../program/libspl.so(+0x11a1e)[0x7fde599f1a1e]
/opt/openoffice4/program/../program/libspl.so(+0x1129c)[0x7fde599f129c]
/opt/openoffice4/program/../program/libspl.so(+0x128dd)[0x7fde599f28dd]
/opt/openoffice4/program/libsofficeapp.so(+0x3c19c)[0x7fde6b1d419c]
/opt/openoffice4/program/../program/deployment.uno.so(+0x54948)[0x7fde582cc948]
/opt/openoffice4/program/libdeploymentmisc.so(_ZN7dp_misc16syncRepositoriesERKN3com3sun4star3uno9ReferenceINS2_3ucb19XCommandEnvironmentEEE+0x460)[0x7fde6a023170]
/opt/openoffice4/program/libsofficeapp.so(+0x3c240)[0x7fde6b1d4240]
/opt/openoffice4/program/libsofficeapp.so(+0x2c857)[0x7fde6b1c4857]
/opt/openoffice4/program/libvcl.so(+0x1807eb)[0x7fde677807eb]
/opt/openoffice4/program/libvcl.so(_Z6SVMainv+0x1e)[0x7fde677808b6]
/opt/openoffice4/program/libsofficeapp.so(soffice_main+0x9c)[0x7fde6b1ecfac]
/opt/openoffice4/program/soffice.bin(main+0xb)[0x400f7b]
/usr/lib/libc.so.6(__libc_start_main+0xf3)[0x7fde6ab5bce3]
/opt/openoffice4/program/soffice.bin(__gxx_personality_v0+0xb9)[0x400eb9]
/opt/openoffice4/program/soffice: linha 121:  2373 Aborted                 (núcleo despejado) "$sd_prog/$sd_binary" "$@"

kingcreole commented on 2019-04-06 08:23

Hey, openoffice does not start on my archlinux, it crashes with a segmentation fault in line 121 of the soffice script, the stack starts with /opt/openoffice4/program/libuno_sal.so.3, contains a lot of /opt/openoffice4/program/libvcl.so and has this maybe interesting bit: /opt/openoffice4/program/../program/deployment.uno.so, any way i can get it to start?

pretty much the same issue as NowG had

oberon2007 commented on 2018-11-21 11:37

PKGBUILD updated

Cray2TheZ commented on 2018-11-20 22:02

Package is now out of date as OpenOffice 4.16 is the newest version.

Installation can still be achieved by downloading the sources with git and editing the included PKGBUILD as such:

_vmin=1.5 ==> CHANGE THIS to _vmin=1.6

Now, run the following command:

makepkg -sri --skipchecksums

Without the --skipchecksums switch, the installation will fail (checking for version 4.1.5's older checksums).

I hope this helps!

NowG commented on 2018-10-11 06:35

Hi, I installed it by the command yaourt -S openoffice, but I get the following error when I tried to start it by openoffice4 -calc.

openoffice4 -calc javaldx: Could not find a Java Runtime Environment! Application Error

Fatal exception: Signal 6 Stack: /opt/openoffice4/program/libuno_sal.so.3(+0x37c3a)[0x7f0a16db9c3a] /opt/openoffice4/program/libuno_sal.so.3(+0x37d6c)[0x7f0a16db9d6c] /opt/openoffice4/program/libuno_sal.so.3(+0x37e09)[0x7f0a16db9e09] /usr/lib/libc.so.6(+0x37e00)[0x7f0a162c3e00] /usr/lib/libc.so.6(gsignal+0x10f)[0x7f0a162c3d7f] /usr/lib/libc.so.6(abort+0x125)[0x7f0a162ae672] /opt/openoffice4/program/libvcl.so(+0x1557b5)[0x7f0a12ede7b5] /opt/openoffice4/program/libsofficeapp.so(+0x2354b)[0x7f0a16b1854b] /opt/openoffice4/program/libvcl.so(+0x17ff06)[0x7f0a12f08f06] /opt/openoffice4/program/libuno_sal.so.3(+0x36a02)[0x7f0a16db8a02] /opt/openoffice4/program/libuno_sal.so.3(+0x37dea)[0x7f0a16db9dea] /usr/lib/libc.so.6(+0x37e00)[0x7f0a162c3e00] /usr/lib/libc.so.6(gsignal+0x10f)[0x7f0a162c3d7f] /usr/lib/libc.so.6(abort+0x125)[0x7f0a162ae672] /usr/lib/libfontconfig.so.1(+0x8026)[0x7f0a08b48026] /usr/lib/libfontconfig.so.1(+0x1d804)[0x7f0a08b5d804] /usr/lib/libfontconfig.so.1(+0x1db3e)[0x7f0a08b5db3e] /usr/lib/libfontconfig.so.1(+0x1dc89)[0x7f0a08b5dc89] /usr/lib/libfontconfig.so.1(FcFontMatch+0x71)[0x7f0a08b5ea31] /opt/openoffice4/program/libvcl.so(+0x13734d)[0x7f0a12ec034d] /opt/openoffice4/program/libvcl.so(+0x1373de)[0x7f0a12ec03de] /opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager20countFontconfigFontsERSt8hash_mapIN3rtl7OStringEiNS2_11OStringHashESt8equal_toIS3_EE+0x35)[0x7f0a12ec1c13] /opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager10initializeEv+0x247)[0x7f0a12ecd21b] /opt/openoffice4/program/libvcl.so(_ZN3psp16PrintFontManager3getEv+0x49)[0x7f0a12ece0df] /opt/openoffice4/program/libvclplug_gen.so(_ZN14X11SalGraphics14GetDevFontListEP15ImplDevFontList+0x2c)[0x7f0a0aa4f136] /opt/openoffice4/program/libvcl.so(+0x25a058)[0x7f0a12fe3058] /opt/openoffice4/program/libvcl.so(+0x260bb0)[0x7f0a12fe9bb0] /opt/openoffice4/program/libvcl.so(_ZNK12OutputDevice13GetTextHeightEv+0x12)[0x7f0a12fec272] /opt/openoffice4/program/libvcl.so(+0x2637fa)[0x7f0a12fec7fa] /opt/openoffice4/program/libvcl.so(_ZN12OutputDevice8DrawTextERK9RectangleRK6StringtPSt6vectorIS0_SaIS0_EEPS3_PN3vcl11ITextLayoutE+0x195)[0x7f0a12ff05f1] /opt/openoffice4/program/../program/libspl.so(+0x11a1e)[0x7f0a02994a1e] /opt/openoffice4/program/../program/libspl.so(+0x1129c)[0x7f0a0299429c] /opt/openoffice4/program/../program/libspl.so(+0x128dd)[0x7f0a029958dd] /opt/openoffice4/program/libsofficeapp.so(+0x3c19c)[0x7f0a16b3119c] /opt/openoffice4/program/../program/deployment.uno.so(+0x54908)[0x7f0a0127d908] /opt/openoffice4/program/libdeploymentmisc.so(_ZN7dp_misc16syncRepositoriesERKN3com3sun4star3uno9ReferenceINS2_3ucb19XCommandEnvironmentEEE+0x460)[0x7f0a1578c170] /opt/openoffice4/program/libsofficeapp.so(+0x3c240)[0x7f0a16b31240] /opt/openoffice4/program/libsofficeapp.so(+0x2c857)[0x7f0a16b21857] /opt/openoffice4/program/libvcl.so(+0x1807eb)[0x7f0a12f097eb] /opt/openoffice4/program/libvcl.so(_Z6SVMainv+0x1e)[0x7f0a12f098b6] /opt/openoffice4/program/libsofficeapp.so(soffice_main+0x9c)[0x7f0a16b49fac] /opt/openoffice4/program/soffice.bin(main+0xb)[0x400f7b] /usr/lib/libc.so.6(libc_start_main+0xf3)[0x7f0a162b0223] /opt/openoffice4/program/soffice.bin(gxx_personality_v0+0xb9)[0x400eb9] /opt/openoffice4/program/soffice: line 121: 4373 Aborted (core dumped) "$sd_prog/$sd_binary" "$@"

simona commented on 2018-08-11 09:35

Can I found openoffice-it-bin and manually install?

simona commented on 2018-08-11 09:15

Thanks :-) I like to have more choice.

oberon2007 commented on 2018-06-13 17:06

@ilkyest there is no newer version. Sources from Apache are still live and identical to the ones on SourceForge.

Cray2TheZ commented on 2018-01-07 20:30

My pleasure (first contribution to the Arch community! Woohoo :D)!

Thanks for the update!